Spotify inactive

I made a new install of 2.001 today and installed the new Spotify plugin but it keeps saying inactive also the save button seems not to work. I don’t get any feedback if I press it

Thanks for any help

Please wait at least 5 seconds after pressing save…
Was it working before or its the first time you use it?

First of all thanks for the quick response :slight_smile: I wait everytime, I already know that it needs some time. It was working with 2.000 but I installed 2.001(not as OTA) today and now it’s not working anymore

Gesendet von meinem Bacon mit Tapatalk

Are you using spotify on another device in the meanwhile? (your phone, another volumio, your PC?)

If that does not work, I will try uninstalling and reinstalling the plugin… Let me know

I have the Spotify application on many other devices installed but I didn’t play any music at one of them. Already tried that, but no success. I think I will just re flash the newest version tomorrow and see if it works. Just wanted to ask here because I thought maybe I missed something.

Gesendet von meinem Bacon mit Tapatalk


Same problem for me. I downloaded and installed yesterday the new volumio version. The Spotify plugin keeps saying inactive and the save button seems not to work on my Raspberry pi 2. I tried to reinstall the plugin but i didn’t help. Spotify application is on my other devices but I don’t play music when i try to activate. Until now I was using the volumio 1.5 version and spotify worked well.

Have you an idea to solve the problem ?

Thank you

The repo containing the required file was down yesterday and maybe today. Thus installation plugin fails. Retry later…

@balbuze Is it the same for your plugin?

Gesendet von meinem Bacon mit Tapatalk

Yes… It is on the same repo… but maybe it’s ok now… I can’t check

So Spotify is working now fine, but @balbuze

Do you use the version from yesterday? I added a message when download fails.

Yes, I use the version from yesterday, it is a different message than yesterday. Yesterday it said “failed to download” and now it just says “Error ok”.

I had the same problem, but realized that even though the Spotify plugin appears as “inactive”, the plugin does work. “Spotify” appears as an option under “Browse”, and I can access Spotify music. So, all good other than the plugin appearing as inactive.

Prior to discovering that the plugin actully works, I tried the following to make the plugin appear as active:

  • shutting down other browsers/apps logged in to Spotify on other devices
  • reinstalling the Volumio plugin