Spotify connect2 not connecting via usb dac

So I’ve been using Volumios Spotify plugin cos the connect2 never worked. Inside the Spotify app I’d select Volumio connect option, it’ll sit there for a while saying “connecting” then time out. However I was messing around with triggerhappy in ssh away from my stereo and thus switched the output device to audio jack to test with headphones. Lo and behold connect2 worked perfectly! Switched back to usb dac and it went back to the timing out behavior. Searching the internet didn’t bring up much useful information, so any input would be greatly appreciated!

Using :
Spotify connect2 0.9.9
System version 2.729
Rpi 3+
Schiit modi 3

Mixer type set to none
Everything else works perfectly

Could you share some logs when you try and connect with the USB DAC? Also what does your look like with you use the USB Dac?

Thank you for the reply! Unfortunately I am really new to this programming stuff and have no clue what I’m doing. I couldn’t figure out how to do the thing but google came up with a way to get the logs. Note that the first time I tried it started a loop that crashed Volumio. Anywho, here it is:

20: 0x76cc3294 - __libc_start_main
volspotconnect2.service: main process exited, code=exited, status=101/n/a
Unit volspotconnect2.service entered failed state.
Stopping Volspotconnect2 Daemon...
Stopped Volspotconnect2 Daemon.
Starting Volspotconnect2 Daemon...
Started Volspotconnect2 Daemon.
vollibrespot v0.1.9 c98fd5d 2019-11-08 (librespot 4674946 2019-11-08) -- Built O                 n 2019-11-08
[Vollibrespot] librespot_connect::discovery: Zeroconf server listening on 0.0.0.                 0:35291
[Vollibrespot] : Failed to register IPv6 receiver: Os { code: 19, kind: Other, m                 essage: "No such device" }
[Vollibrespot] : ConnectRequest: "Spotify/8.5.51 iOS/13.4 (iPad5,3)"
[Vollibrespot] librespot_connect::discovery: ConnectRequest: Some("action=getInfo")
[Vollibrespot] : ConnectRequest: "Spotify/8.5.51 iOS/13.4 (iPad5,3)"
[Vollibrespot] librespot_connect::discovery: ConnectRequest: None
[Vollibrespot] librespot_connect::discovery: POST "/" {}
[Vollibrespot] : Connecting to AP ""
[Vollibrespot] : Authenticated as "3uzo5pzd8wxe1da0r7jid7ae1" !
[Vollibrespot] librespot_core::session: new Session[0]
[Vollibrespot] : Setting up new mixer: card:hw:5 mixer:PCM index:0
[Vollibrespot] : Alsa min: 0 (MilliBel(0)[dB]) -- max: 0 (MilliBel(0)[dB]) HW: false
[Vollibrespot] : Switching to linear volume mapping, control range: MilliBel(0)
[Vollibrespot] : Alsa min-db is not SND_CTL_TLV_DB_GAIN_MUTE!!
[Vollibrespot] librespot_connect::spirc: new Spirc[0]
[Vollibrespot] librespot_core::mercury: new MercuryManager
[Vollibrespot] librespot_playback::player: new Player[0]
[Vollibrespot] : Using alsa sink
[Vollibrespot] librespot_connect::spirc: linear volume: 0
thread 'main' panicked at 'Couldn't get current volume: Error("snd_mixer_selem_get_playback_volume", Sys(EINVAL))', src/libcore/
stack backtrace:
0:   0xa2b788 - backtrace::backtrace::libunwind::trace::h89fcc71e59e3bc5b
at /cargo/registry/src/
1:   0xa2b788 - backtrace::backtrace::trace_unsynchronized::h244e30b4d61a86e0
at /cargo/registry/src/
2:   0xa2b788 - std::sys_common::backtrace::_print::h978df54e55c6209d
at src/libstd/sys_common/
3:   0xa2b788 - std::sys_common::backtrace::print::ha75ae47f14b8f7f3
at src/libstd/sys_common/
4:   0xa2b788 - std::panicking::default_hook::{{closure}}::h004e1d529e652ede
at src/libstd/
5:   0xa2b380 - std::panicking::default_hook::h185ef7ff1eea4221
at src/libstd/
6:   0xa2bf44 - std::panicking::rust_panic_with_hook::hfe0a86ed15580d4a
at src/libstd/
7:   0xa2bb10 - std::panicking::continue_panic_fmt::h182e68ecbb1c932b
at src/libstd/
8:   0xa2b9fc - rust_begin_unwind
at src/libstd/
9:   0xa42444 - core::panicking::panic_fmt::h7e9f94035af782b3
at src/libcore/
10:   0xa42534 - core::result::unwrap_failed::hf7591c1dd9412006
at src/libcore/
11:   0x5727d8 - librespot_playback::mixer::alsamixer::AlsaMixer::map_volume::hc3941422653c99d0
12:   0x573194 - <librespot_playback::mixer::alsamixer::AlsaMixer as librespot_playback::mixer::Mixer>::set_volume::hb83ffa4c77bee9be
13:   0x4dbf70 - librespot_connect::spirc::SpircTask::set_volume::h377a17551ebc8992
14:   0x4d6e08 - librespot_connect::spirc::Spirc::new::h321dd080a56e195c
15:   0x4acb70 - <vollibrespot::Main as futures::future::Future>::poll::hb49550d8e3f467fa
16:   0x4d29b4 - futures::task_impl::std::set::hb572c3af727256ac
17:   0x4aae2c - <futures::future::lazy::Lazy<F,R> as futures::future::Future>::poll::hc872efa618c45de3
18:   0x4d283c - futures::task_impl::std::set::ha1da852080a54e89
19:   0x497894 - std::thread::local::LocalKey<T>::with::hb33a14aa0d64830e
20:   0x48dc1c - tokio_current_thread::Entered<P>::block_on::h6c7f92e99b77886b
21:   0x4976b4 - std::thread::local::LocalKey<T>::with::h9ec9ec76b26e7edf
22:   0x49730c - std::thread::local::LocalKey<T>::with::h26f52d592cd722ab
23:   0x49716c - std::thread::local::LocalKey<T>::with::h22d8fcf69243240c
24:   0x48d1e0 - scoped_tls::ScopedKey<T>::set::h3380ded7e37a7882
25:   0x4c6ee4 - tokio_core::reactor::Core::run::h9c6fa799f1a72320
26:   0x4af3ec - vollibrespot::main::h551d8fa54606fabf
27:   0x4b60ac - std::rt::lang_start::{{closure}}::hdc0b123e45936b4e
28:   0xa2b974 - std::rt::lang_start_internal::{{closure}}::h923917fc45a67b03
at src/libstd/
29:   0xa2b974 - std::panicking::try::do_call::he118fbfc301d3e1a
at src/libstd/
volspotconnect2.service: main process exited, code=exited, status=101/n/a
Unit volspotconnect2.service entered failed state.
30:   0xa2fe54 - __rust_maybe_catch_panic
at src/libpanic_unwind/
31:   0xa2c3c0 - std::panicking::try::hcc03ea850c2702cb
at src/libstd/
32:   0xa2c3c0 - std::panic::catch_unwind::hf09eaf9043e449c8
at src/libstd/
33:   0xa2c3c0 - std::rt::lang_start_internal::h87508684140f3dc4
at src/libstd/
34:   0x4b03f8 - main
35: 0x76c69294 - __libc_start_main
[Vollibrespot] librespot_connect::spirc: drop Spirc[0]
[Vollibrespot] librespot_playback::player: Shutting down player thread ...
[Vollibrespot] librespot_playback::player: drop Player[0]
[Vollibrespot] librespot_core::session: drop Session[0]
[Vollibrespot] librespot_core::mercury: drop MercuryManager
[Vollibrespot] librespot_core::session: drop Dispatch
volspotconnect2.service holdoff time over, scheduling restart.
Stopping Volspotconnect2 Daemon...
Starting Volspotconnect2 Daemon...
Started Volspotconnect2 Daemon.
vollibrespot v0.1.9 c98fd5d 2019-11-08 (librespot 4674946 2019-11-08) -- Built On 2019-11-08
[Vollibrespot] librespot_connect::discovery: Zeroconf server listening on
[Vollibrespot] : Failed to register IPv6 receiver: Os { code: 19, kind: Other, message: "No such device" }

Sorry about not posting instructions, but your google foo is quite good :wink:

For your issue, it looks like your DAC doesn’t have a MONO channel, and this is failing when querying the volume.
What is the output of


That should list the playback channels for your DAC, among other things.

PS: For future use, you can wrap your logs in [code]... [/code ] to have them formatted and readable :slight_smile:

Solution from @robfrye who has the same DAC:

It works for me, thanks

1 Like


I have also been having a similar issue with a Zishan z2 usb dac.

If I use it in hardware or none mixer mode, it will time out when trying to use spotify connect but it plays everything else (web radio, flash drive, nas) beautifully. Spotify natively will play but the audio will sound sped up, not good.

If I switch to software mixer it will pair with spotify connect but the sound comes out horribly distorted, especially the bass. NAS, web radio, and any other source I tried also sound distorted with software mixer.

Any fixes or recomendations?