Spotify Connect


firstly I’m completely new to programming and the Raspberry, so please don’t expect me to know a lot.
I got a Raspberry Pi 3 Model B (no DAC) and i was trying to connect my Spotify premium account to it via the plugin, but it doesn’t work.
‘volumio’ is shown as a device on my Pc/ Android smartphone in the Spotify app, but it won’t connect when clicking on it.

Sorry for the bad english, I hope you understand it.

There is an updated version waiting to be merged. If you want to install it unofficially, visit Balbuze’s github.

Thanks for the answer.
I already tried that but after typing ‘volumio plugin install’, it shows something like ‘couldn’t find package’.

Please follow exactly the instructions given in the

Is there any command/way to delete a package or a path?
Because this appears:
'volumio@volumio:~/volspotconnect2$ volumio plugin install

This command will install the plugin on your device

No package found’

Because I’d like to remove the whole package/path and reinstall it.

Okay tried myself and could delete it.
I just installed the plugin and now it’s working.

Thank you very much :slight_smile:

On a Raspberry 3, I followed your instructions. Thereafter, the WebGUI shows “Volumio Spotify Connect 2, 0.9.7” under installed plugins. When activating the plugin, I was not asked for spotify username and password :confused: and there is no spotify symbol in the search window of the WebGUI.
What do you recommend me to try?

First, the plugin is available as “official” plugin. So no need to use SSH.
Second. Spotify connect is to be used from the official Spotify application. You’ll see nothing in webUi, except settings for the plugin.

I did the SSH procedure, because with the official plugins, volumio does nothing with spotify’s playlists. Sorry for not telling the whole story.

Now, I installed both official plugins and can play single tracks and albums and add them to the queue as well. But I can’t do anything with spotify’s featured playlists although I see them in WebGUI.