Spotify Connect

Nice! After some fiddling around with chroot I got this up and running. One small question though:
Does anyone know how to make the device name permanent? When I run ./ --username 12345678 --password xyz123 --bitrate 320 the pi shows up as “TestConnect” (remote name: TestConnect). Accessing the WebUI under http://ipaddress:4000 it’s pretty easy to change that name but as soon as I stop and restart chroot it goes back to the default name.


just add --name Myname in the command line so that having : --name Myname --username 12345678 --password xyz123 --bitrate 320 :wink:

Great work! Volume control is working great for me. I’m running Raspbian (RetroPie image) on Raspberry Pi 1 B.

I also set the script to execute on boot so I can easily use raspberry for Spotify Connect with any speakers with auxiliary input.

Thx! That was easy :mrgreen:

How did you do that?

I tried adding:

/home/pi/ --name Myname --username 12345678 --password xyz123 --bitrate 320 &

to the /etc/rc.local but nothing happens on startup …

ok im just stupid… forgot to add sudo :confused:

Perhaps not the correct place to post this but i am guessing the people how read this might also wonder.

Has anyone managed to get multicast with Spotify Connect?

Streaming music to more than one speaker at the time?

( also thanks for the helpful comments, got me up and running so :slight_smile:

I dont´understand the following line:

# Copy your `spotify_appkey.key` into the app directory. (See below for information on how to get that file.) sudo cp spotify_appkey.key spotify-connect-web-chroot/usr/src/app/

Where is the “spotify-connect-web-chroot/usr/src/app/” folder?eers

Cheers, Tom

Once you have installed the chroot pre-build, you have a new directory in your user home folder called spotify-connect-web-chroot .
for instance, if you did with PI as user you should have /home/pi/spotify-connect-web-chroot .
Cd in this directory, then cd to usr/src/app and place here your key.
This is the same thing than sudo cp spotify_appkey.key spotify-connect-web-chroot/usr/src/app/ (if the key is in the directory from where you type the command. :wink:

Spotify doesn’t allow this, not even on the same network… I would’ve gone premium sooner if they did. They might allow this with the official manufacturer stuff though, or the manufacturers found a way around it re-streaming to other speakers. But spotify only allows one stream at a time.

Thanks, than i havent missed anything :slight_smile: Just wanted to make sure.

I must be stupid, I doesn´t work like expected :confused:

What I did:

  1. login as root
  2. cd /tmp
  3. curl -O spotify-connect-web.s3-website.e …
  4. chmod u+x
  5. from /tmp I do ./ install
  6. after that download I find the “spotify-connect-web-chroot” under “/root/spotify-connect-web-chroot”
  7. I copy my spotify_appkey.key to /root/spotify-connect-web-chroot
  8. with ./ --username myusername --password mypassword --bitrate 320 I get the following error:

Traceback (most recent call last):
File “”, line 9, in
from connect import Connect
File “/usr/src/app/”, line 8, in
from console_callbacks import audio_arg_parser, mixer, error_callback, connection_callbacks, debug_callbacks, playback_callbacks, playback_setup
File “/usr/src/app/”, line 16, in
audio_arg_parser.add_argument(’–mixer’, ‘-m’, help=‘alsa mixer name for volume control’, default=alsa.mixers()[0])
IndexError: list index out of range

Is there soemthing I do wrong :question:

Has anyone an idea? :confused:

1 - I put my key in ./spotify-connect-web-chroot/usr/src/app
2 - Your problem seems to be a problem with alsa. You can try to use a different miser by adding -m mixername or -D devicename in your command line

edit : have a look a the repo some work has been done to avoid problem with alsa.

I got this to work and it’s fantastic, but having major trouble switching to Airplay or MPD rendering while the Chroot is running.

In fact, in the base version, spotify-connect keep alsa device even when not playing music.
With this fork when not playing spotify-connect, you can use mpd (don’t know for airplay). You have to stop mpd playing and not pause to be able to use spotify connect. In the same way you have to stop playing spotify to use mpd.

Sweet - just getting Volumio2 alpha up and running, little disappointed to see it’s still spop for now, but fingers crossed it makes the full build.

Scratch that.

Wonder could I use the new code here: … f107b42c6f and inject it into Volumio somewhere so it automatically kills the daemon once it detects MPD/Airplay initiating, and restarts it on stop…

Maybe I don´t understand it well but I thought MPD always plays music in volumio, regardless which way the music arrives at the Pi … Airplay or Spotify-Connect?

Can anyone explain in easy words?

mpd is not used for spotify connect nor spopd ( the Spotify implementation in volumio) or spotify-connect.

Ok, will it harm the quality of playback?