I’ve been using spotify-connect-web as a server in order to use my volumio as a Spotify Connect device. I used this manual ( … bedienung/ it’s in german, but a google translate is good enough to follow it). So far, so good in v1.55

Enter v2, RC2. I’m trying to run it at the startup, but I am not able to do it. I think that the change in the last version, that removes the root user, has something to do, but I am not an expert in linux and am not sure.

Im trying to add this line to rc.local, but it doesn’t work.

/home/volumio/./ --name Volumio --username Imanidiot --password Dontpostyourpassontheinternet --bitrate 320 & > /dev/null 2>&1

If I start the server manually, it works as expected. If I put it inside a script, it asks me for the root password, and if I sudo the script, it throws me an error:

volumio@volumio:~$ mount: mount point /root/spotify-connect-web-chroot/dev does not exist umount: /root/spotify-connect-web-chroot/dev: mountpoint not found umount: /root/spotify-connect-web-chroot/proc: mountpoint not found

Argh, I’m too tired, I’m going to sleep. Hope you can help me.

not seams that the root has removed.

if you do sudo su (pass volumio)
you can browse to the /root folder

perhaps you can test by repeat all the installation as a root with sudo?

btw the SPOTIFY-CONNECT-WEB could be one of the nices plugins to be. Hopefully the info flows soon and put all in a plugin

hope this help

I think I tried that, but I messed up so much, typing commands that I didn’t understand copied from the internet, that I might have broken something. I will try with a fresh install.

I remember reading a while a go in a lost post somewhere that there were problems making a plugin, that it might be better to wrap it around a C daemon. I don’t know the implications of this, it this will be made into a plugin or if it will be a “service” of the system. In any case, I think that right now the efforts are focused in other areas.

In the worst of the cases, I am able to run it manually. It’s a bit of a pain to do it every time I reboot, but I don’t reboot even weekly, so it’s not a big deal. It certainly reduces the WAF factor of my build.

Hi, can anyone help me- i’ve tried to follow the instructions on that german website, but when i come to the last bit to test the installation, i get this message:

Traceback (most recent call last):
File “”, line 11, in
from flask_cors import CORS
ImportError: No module named flask_cors

From reading around, it seems i might have to install something called flask cors, but i can’t work out how to do this- i’m afraid i’m not that au fait with how to do anything there- my experience thus far has largely been to find command lines on the internet and copy them to do what i need.