Spotify Connect - Volumio doesn't show up on Android

Volumio isn’t showing up as a device option in Spotify on my Android device, but it does show up in Spotify on my laptop (Windows 10). They’re both on the same network.

Any ideas as to what the problem may be?

What version of the plugin does this happen with?

Can’t find the version number, but the plug-in menu says it was last updated on 20-3-2018, so I’m guessing it’s the latest?

Hmm, yes unfortunately, the UI doesn’t have a way to show the plugin version right now.
You could see the current version via ssh with cat /data/plugins/music_service/volspotconnect2/package.json
There were some issues with the old version of the plugin and the new Android client but that should be solved. Unless Spotify changed the Andorid client again, what version of the Android client are you on?

I’ll try to pull the exact version # later. As for Spotify, I’m on version 8.4.46.575

I can second that, I have extactly the same problem. But unfortunately I assume this is an Android and/or Spotify problem because I have the same effect when I run LibreElec with the Spotify Addon.

But I would be more than glad if there was a solution for that… :slight_smile:

I have the same thing happening.

I’ve got the latest version of Spotify connect from here: github.com/balbuze/volumio-plug … /readme.md

My desktop sees Volumio no problem, and my Android phone can see it once I’ve started playing on Volumio from the Desktop, but not before.

Would be interested to see if anyone has a fix as I’m looking at setting up a second Volumio instance connected to an amp in the garden…

:smiley:

sorry to resurrect old thread, but having same problem now. Connect plgin version 1.0.5, volumio 2.861, android spotify client 8.5.93.445

I couldn’t even get my linux spotify client to see volumio until I turned off multi-user mode in the connect plugin settings and put in my account info. Now it works from my linux box but not android.

Interestingly, if I begin playback on volumio from my laptop, then open android client, it continues to play on volumio and indicates on android client that it’s playing on volumio. I can change songs, all controls work well, I just can’t initiate a connection between android spotify and volumio because volumio never shows up as an option.

Discovery requires MDNS packets to be forwarded by your network – try checking if you can see the packets using a mdns service browser. Unfortunately, this is something quite network dependent, so I can only give you a few pointers on debugging and can’t help directly…

Do you know whether the android app “Volumio” uses MDNS packets to discover a volumio instance on the network? The Volumio app on android discovers the volumio server instance on the network just fine.

Also, what about the android app “Service Browser”? That app reports “_Volumio._tcp.” as a service on my network.

I’ll look for a general purpose MDNS service browser and try that too. What kind of output should I be looking for in a healthy setup?

The Volumio mdns is not as involved as Spotify connect - but it is a good sign that you see it.

Turn on debug mode in the plugin settings and share some logs?
Preferable via ssh.

# vollibrespot logs
journalctl -f -o cat -u volspotconnect2.service

If you see _spotify-connect._tcp then the daemon is doing what it should do, and the network is allowing these through.

The next step would be to run the desktop client with verbose logging, and see if it picks up this broadcast.

avahi on manjaro is showing me the volumio mdns but not _spotify-connect._tcp

I haven’t checked the debug logs yet, but will do so.

For the sake of discussion and because I have your attention :slight_smile: - if my router is blocking these packets what is the typical remediation? This is just a bone stock Arris unit for ATT fiber.

As a quick test, you could install the i386 version of vls on your desktop and confirm if discovery works then – That should narrow down the debugging to the hop b/w your device (pi?) and desktop.

I haven’t fired up the debugging yet (sorry), but I should clarify that volumio shows up on literally all my other spotify devices (three laptops, an iphone, and an amazon tablet) - just not on my OnePlus 7 Pro. Does that give any clue?

Unfortunately, I really can’t help - the Spotify clients are quite moody when it comes to discovery. Furthermore, their change logs of “Fixed some bugs, minor performance improvements” doesn’t help either :expressionless:
If you are only a single user, I’d recommend signing into your account on the device to reduce hassles.