Spotify Connect not connecting to Volumio

Please, I hope you noticed that Spotify connect is a FREE plugin, wrote on spare time :thinking:

Send log rather than images…It would be more useful.
And last, it works as expected (I use it while writing…)

1 Like

I think balbuze wants you to get this type of logs

https://volumio.github.io/docs/User_Manual/Sending_logs_for_troubleshooting.html

1 Like

Sorry.
http://logs.volumio.org/volumio/VFyN4qx.html

1 Like

Here is the log, thanks! I only use Spotify, so my alternative is to skip Volumio, but I would be happy to pay for the plugin or to make it work!
Thanks in advance from Copenhagen

http://logs.volumio.org/volumio/nowZytm.html

I posted the log. If you or anyone can make it work, I will happily pay 100 USD to make it work. My alternative is to buy an external DAC.

please disable the plugin Spotify.
Spotify connect can’t load file.
Do you have have Spotify non free account?
Do you use shared device in plugin settings?

thanks for reply.

I have factory reset all of Volumio.
I have a paid Spotify account.

I have only installed the Spotify connect plugin.
If it is set to “shared device” Volumio is greyed out in Spotify and says “cannot connect”.
If set to “private user”, it spins though songs and does not work.

However, after I facoty reset it, I also reset the Spotify password. However, now it keeps saying “wrong password or username”. It is the username (not email) and password as set in device password in Spotify.

Again, I am happy to pay to make it work. I love my DAC hat and I have screen and Volume control ready :slight_smile:

Oscar

For me Spotify Connect is only working with the VIRTUOSO activated device. I am randomly using Spotify, thus I sort of remember is was working on all my devices untily the last or the last but one Volumio 3 version.

Spotify connect for Volumio is NOT linked to Myvolumio account. It is based on a fork of librespot, a free implantation. :wink:

Yes I believe that’s the aim, but obviously NOT for me :frowning_face: and some others folks in this thread.

Seriously, I checked more than one time, with all the hints, cheats, ON/OFFs and reboots from above. No way to make it working. The devices name is showing up in the Spofity app, connecting, connecting, … and falling back to the original output device. That’s reproducable for all of my three devices. You are the expert - anyhow something stops the show.

@cgs
you’re connecting to the correct instance of Volumio? Every Volumio instllation here spits 2 connection.
<devicename>
<devicename>-UPnP/AV
Only the latter seems to be working, most of the time.

Still it’s not foolproof:

  • after pause, I need to change the output and change it back to Volumio in order to have a connection
  • Spotify connect stops on random intervals, so I need to repeat the first step

@Wheaten @balbuze Thanks for the support. Setting the “Mixer Type” in the “Volume Options” to “None” makes it working all the time, also if VIRTUOSO is diabled. I have to apologize insisting on this dependency.

1 Like

Same. Spotlight connect stopped working. The plugin (2.0.3) cannot authenticate anymore. Password is correct.

Plugin 2.0.3 is the Spotify plugin for use inside Volumio that has stopped working, for Spotify Connect you should use the other plugin called Volumio Spotify Connect (3.0.8)

They will both be replaced by a new plugin that you can beta test now.

1 Like

Same here: Mixer type NONE is required, for my setup, for Spotify Connect plugin to work. And it works perfectly, thank you @balbuze!

Sidenote: Every time I start Volumio internet radio, the radio starts ok, then stops for some reason and sets mixer type to hardware…

With the beta plugin, Volumio is not seen by the Spotify app unless I start Spotify playback from within Volumio’s GUI.

EDIT: reported issue in the dedicated thread as suggested by @Wolfman74 below.

Maybe better that you report the issue in the thread dedicated to the new plugin, since simular issues been reported there!

HI!!! I tested the last version, and when i have connected to volumio, the spotify songs are skipping automatically each 2 or 3 seconds. I´m using a raspberry pi 3 B+, with v2.907.

Hi, I face the same issue but cannot reproduce traceable the behavior.
I have a freshly and latest Volumio 3 build, premium plan, with no plugins accept latest Spotify plugin.
Hardware is Raspberry 4 with Hifiberry DAC + pro, with WIFI connection

While sometimes it plays stable when streamed from Smartphone or PC, after some trials it makes what you describe but faster. Would say every two seconds it is like pushing the skip button but with no tone.

Much harder is, that

  1. sometimes the player visibility will only be populated by Spotify app when opening the Spotify plugin and click the Spotify button on the Volumio GUI first.
  2. I am not able to play Spotify music in Volumio directly from new Spotify plugin. Only streaming works from Smartphone to Volumio. When click the play button, red popup with Spotify REST API failure pops up
  3. When installing the Spotify plugin the screen do not update after S. premium log in. Then however after Reeboot the plugin shows the valid log in.
  4. Normalize Volume in the plugin is not possible how often I press this button.

Besides that on my other Volumio 3 player with the same config but Khadas Tone One and DLNA Server plugin installed I have the same issues.
I put in all failures here in one post, because maybe one failure depends on the others or there is one big failure.
Please support us.
Thank you in advance and have a nice evening
Cheers
Benjamin from Francoforte