Spotify Connect not connecting to Volumio

I cannot get Spotify connect to work.

In Spotify it shows up in the app, tries to connect but then stops.

The raspberry pi got a new fresh install of volumio 3. As well I’ve reinstalled the plugin. Restarted the device and restarted the network. And the spotify app.

More people having this problem?

Volumio version?

Would you share some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

1 Like

Volumio 3.175

Fresh reboot.
Trying to play trough Spotify connect to Volumio.
It shows up in the app, Mac and iPhone. But cannot connect to Volumio.
Spotify continues to play on another device.

Share link to the log.


There appears to be a problem authenticating at the Spotify servers. Are you sure that you have a premium account?

There have also been a couple of similar reports in the last month or so. It worked fine when tried later (so something temporary at the Spotify end).

It’s a family account :confused: but paying for it. Used to work in Volumio 2, and does work on the denon receiver.
Reinstalling the plugin doesn’t work as well.

1 Like

I have family account, and it works fine for me.(so that’s not the issue)

I have the exact same issue. I have already tried to reboot Volumio and to reinstall the plugin.

Suddenly it works. Spotify connects to volumio. Then I didn’t have any sound. Played around with settings. After restart it worked.

Looks like everything you change in the plugin needs a restart. I’ve had it with normalization. This is now turned off in the plugin, on in the basic settings.

If I may be permitted to hijack… same issue here, and it doesn’t seem solved to me?

I have a Spotify Premium account. Freshly installed on a new Pi Zero W, with Hifiberry DAC+. I have two Spotify plugins installed, but only enabled Volumio Spotify Connect2. It’s currently set to Multi-user device - I tried setting it to only my personal account, but after restarting Volumio, Spotify on both my android phone and Windows10 laptop did not even see the device… Now that it’s set to Multi-user, Spotify recognizes it but doesn’t connect. Any idea on how to solve this?

[edit] Link to log

Same for me too

Appears to be when I have a HAT on - it’s fine wen I switch off i2c

Works fine as USB out. Just HATs is the problem…

Did anyone solve this?
I have an Audiophonics ES9038Q2M DAC HAT… & Volumio 3.
Installed - removed access to Vlumio, reinstalled - reanabled.
installed both Spotify plugins (like I did with Volumio 2)
I can play Spotify from Volumio but not the other way around.
I see the “Volumio” in Spotify Connect, but when I choose it, it does not go to play out there.

I suspect a problem with the volume mixer. To check, set volumio on software mixer. Disable and enable the plugin.
Let me know.

  1. I tried to set to software mixer, saved
  2. I tried to set uninstall and reinstall the plugins (both) for Spotify & re-connecting the email & password
  3. Restarted Volumio
    (that would set it back to “hardware”)
  4. I set it again to software, saved
  5. Disableed and Reenabled plugins
  6. Restarted Spotify
    I see “Volumio” as playback option in Spotify, but it only lights green for a second.
    Sameproblem: I can play Spotify from Volumio but I cannot use “Spotify Connect”.

One interesting observation - when I choose Volumio in Spotify - Volumio webinterface writes “Spotify Connect is Active” as a banner for 2 seconds. See here

Any suggestions would be very much appreciated :slight_smile:

Can you check the images I uploaded 2 weeks ago? Happy to pay for Volumio, but it needs to work :wink:

Hi! I have the same problem with Spotify connect and Volumio (last version).

Please, I hope you noticed that Spotify connect is a FREE plugin, wrote on spare time :thinking:

Send log rather than images…It would be more useful.
And last, it works as expected (I use it while writing…)

1 Like