Spotify Connect just stops playing

I am on 3.324 and the latest Spotify plugin, however I have had this issue with multiple versions of Volumio as well as on the current Spotify plugin as well as the old one. Basically, I will be playing music via Spotify Connect to Volumio and after some number of songs (sometimes several, sometimes just a few) the music will just stop playing and the Spotify app on my phone will show that I have disconnected from the Volumio client. I can reconnect and start playing the track again, but it is a PITA and happens fairly frequently. Log below for when the disconnect happens, playback stopped in the middle of the track “I’m Not My Season”. I am by no means an expert, but I have tried other fixes I have read about on the forums (e.g. changing mixer type, reinstalling/disabling and re-enabling the plugin) and I am connected via 5GHz wifi and very close to the access point. Also, playing Spotify via Airplay works fine for hours on end, so I seriously doubt it is a network/signal strength issue. Any help is much appreciated!

info: CoreCommandRouter::volumioGetState
info: CoreCommandRouter::volumioGetQueue
info: CoreStateMachine::getQueue
info: CorePlayQueue::getQueue
info: CoreCommandRouter::executeOnPlugin: system , getHwuuid
[Vollibrespot] : couldn’t parse packet from 192.168.0.238:5353: query type 65 is invalid
[Vollibrespot] : Loading with Spotify URI
[Vollibrespot] : (191400 ms) loaded
[Vollibrespot] : Event: Next { track_id: SpotifyId { id: 214232179337690954136126674765395705785, audio_type: Track } }
[Vollibrespot] : Event: TrackChanged { old_track_id: SpotifyId { id: 242099742719394636861820039978163288053, audio_type: Track }, track_id: SpotifyId { id: 214232179337690954136126674765395705785, audio_type: Track } }
[SpotifyConnect] I’m Not My Season
info: Is Connect Playback
info: [1659539456193] ControllerSpotify::pushState
info: CoreCommandRouter::servicePushState
info: CoreStateMachine::pushState
info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
info: CoreCommandRouter::volumioPushState
[Vollibrespot] : Unable to load audio item.
[Vollibrespot] : SessionError: Connection reset by peer (os error 104)
volspotconnect.service: Succeeded.
volspotconnect.service: Service RestartSec=2s expired, scheduling restart.
volspotconnect.service: Scheduled restart job, restart counter is at 9.
Stopped Volspotconnect2 Daemon.
Started Volspotconnect2 Daemon.
vollibrespot v0.2.5 8922128 2022-05-31 (librespot 08d8bcc 2020-10-07) – Built On 2022-05-31
Reading Config from “/tmp/volspotify.toml”
[Vollibrespot] : Using Alsa backend with device: volumio
[Vollibrespot] : Failed to register IPv6 receiver: Os { code: 19, kind: Uncategorized, message: “No such device” }

Please reply in the origanal topic, so the peeps from Volumio can keep track of everything.

Will do, apologies.

no problem, thanks!!