Spotify Connect 2 ver 1.0.3 Why is the sound quality worse than on the Spotify plugin?

Hi!
I have both plugins installed. I have chosen bitrate 320 on both and yet the sound quality is noticeably worse if I listen through the Spotify connect plugin. Is there some hidden config that can help with this or is is something else that differs? With noticeably I mean that spotify connect sounds harsher and a bit more tinny. I’m listening with headphones (AKG K612) but I guess you could miss it listening to a less revealing system.

Hardware is rpi 3b+ and justboom digi hat connected to my marantz amp/dac so there shouldn’t be any difference there.

1 Like

What is your mixer configuration and do you have volume normalisation on?

For some background:

Sounds like similar issues!

I have no mixer enabled and no normalisation. I’m a bit confused because I can still change the volume from the Spotify app using the connect plugin.

Could you post details of your mixer setup?

If you have no mixer enabled (i.e, “None” in the playback settings page) then you shouldn’t be able to change the volumio via the Spotify app…

If playback mixer is set to none, the plugin fall back to its internal volume mixer. Then you can still set the volume from Spotify.

Hmm, shouldn’t it for mixer None first show the “Initial Volume” slider and default volume_ctrl to fixed?

@gorgias
When mixer is None it should also allow you to set an initial volume, and let you choose the Internal Volume Control. In your case, try seting the initial volume to 100, and Internal Volume Control to “Fixed”

yes you’re right, default is ‘fixed’

I will try later. What does fixed mean here? Can I still use Spotify volume control when set to fixed? It would be good with some explanation in the plugin settings page maybe, to clarify.

I have tried using software mixer in volumio before and that did not change the sound quality in any perceptible way.

Normally the little 🛈 information icon gives you a little more details about each settings.
In this case, it turns off the internal software volume implementation, and doesn’t let you change volume from the app, similar to the None mixer in Volumio.
Setting the initial volume slider to 100, should then result in the same output as what you get with the Spotify plugin.

Ok, now I have tested some more.

Volumio mixer set to none
Plugin mixer set to fixed
Initial volume 100

Now I can’t change volume from Spotify app.
The difference of sound quality remains.

I would describe it as the air in the music is gone with Spotify connect. And as I said before, there’s a harshness in the sound that is tiering. I bet it is some format conversion going on. Volumio displays 16 bit 44 khz when using Spotify connect if that is of importance.

I am not really an expert in audio processing, but I can shed some light on the implementation for the Spoitfy Connect plugin. The daemon decodes the Vorbis 44100 Hz stream for Spotify’s servers to pcm data. This stream undergoes two operations

  1. Volume adjustment if software volume is enabled.
  2. Gain normalising if “Volume normalisation” is enabled

If both of these are disabled (as you have set it up now) then the decoded PCM stream is directly fed to ALSA’s buffers.

The Spotify plugin, on the other hand uses SoX aka “Swiss Army knife of sound processing”.
I haven’t looked into it details - but it could be that there are some audio processing being carried out by it that makes it sound better to your ears?
You could look into spop’s logs to confirm if it is indeed applying some effects via SoX…

How do I see that log file?

I just made this comment on github:

Hi,
I have the same problem with poor sound quality.
I tried the above command to see the log from volspotconnect 2 and everything looks ok except for this line:
[Vollibrespot] : Reducing normalisation factor to prevent clipping. Please add negative pregain to avoid.

edit:
I have normalisation off in spotify and mixer disabled in volumio.

Tried to start alsamixer via ssh in volumio and pcm volume was set to 100, can this be the problem?

I haven’t had time to compare sq yet…

This means that you haven’t toggled the Volume normalisation off in the plugin settings.

Nope, if you set your “Initial Volume” slider to 100, then this is as expected – 100% volume with mixer controls disabled.

I am 100% sure that I checked normalisation off in the plugin and I have also confirmed it i config,json.

If init volume = 100 means clipping, then I say the plugin is badly designed.

Don’t get me wrong here, just trying to help…

Sorry, I was actually wrong there, it isn’t being applied. :confused:
This warning is just about adjusting the normalisation factor to avoid clipping. Basically Spotify encodes a track’s peak gain in the file, and we parse this and check if the normalisation_pregain parameter would lead to clipping, then then automatically reduces it to avoid clipping.
But these are all just warnings – no normalisation will be applied to the stream unless the “Volume normalisation” is enabled.