Spotify Connect 2 does not work

Hello to all,
sorry for my English. I can’t get Spotify Connect 2 plugin to work.
The installation is successful, the activation also, Spotify reads the presence of Volumio among the available devices, when I select it to make it connect it appears “connection in progress” but after a few seconds it stops and everything goes back as before.
I can’t find similar problems in the community, or at least I can’t find similar problems with resolution that I understand.
Can someone help me?
Thank you very much

Could you share some logs?

Either from the /dev page using the livelog feature or via ssh.

# Volumio logs
journalctl -f -o cat
# vollibrespot logs
journalctl -f -o cat -u volspotconnect2.service

Note you might need sudo before these commands depending on the version of Volumio your running

I would guess it fails to figure out the correct device/mixer and hence fails.

sorry, i’m very beginner. I do not understand how to do these things you say…
anyway I try to inform myself about other sites to better understand how to log in

Ah, the easiest would be to navigate to the /dev page and see the livelog section… - so this is just via the browser as with the normal WebUI – volumio.local/dev and replace thevolumio with your actual device name.

Start a logging session from there, and then try and connect via the Spotify app. You should see some lines of logging, that if you share here should help figure out what issues your facing :slight_smile:

Also would be helpful to describe your setup (what board, what DAC, Volumio version, etc etc)

Hi, i have this:

  • Raspberry Pi 3 Model B+
  • linked with USB cable to:
  • Cambridge Audio CXA80 (with his internal DAC Wolfson WM8740)
  • Volumio version 2.834

This is the log recorded when I tried to do what you told me:

Starting Live Log...
info: CoreStateMachine::getQueue
info: CorePlayQueue::getQueue
info: CoreCommandRouter::executeOnPlugin: system , getHwuuid
error: error
error: error
error: error
error: error
info: CALLMETHOD: system_controller system enableLiveLog true
info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog
info: Launching a new LiveLog session
[Vollibrespot] : Connecting to AP ""
[Vollibrespot] : Authenticated as "31jtkkcwt53kagrpa7xetu3utmna" !
[Vollibrespot] : Setting up new mixer: card:hw:5 mixer:CA CXA80 1.0 Output index:0
[Vollibrespot] : Alsa min-db is not SND_CTL_TLV_DB_GAIN_MUTE!!
[Vollibrespot] : Alsa Mixer info min: 0 (MilliBel(0)[dB]) -- max: 0 (MilliBel(0)[dB]) HW: false
[Vollibrespot] : Switching to linear volume mapping, control range: MilliBel(0)
[Vollibrespot] : Alsa min-db is not SND_CTL_TLV_DB_GAIN_MUTE!!
[Vollibrespot] : Using alsa sink
thread 'main' panicked at 'Couldn't get current volume: Error("snd_mixer_selem_get_playback_volume", Sys(EINVAL))', /build/cache/git/checkouts/librespot-6f197fd632ef9380/08d8bcc/playback/src/mixer/
stack backtrace:
0:   0xa5733c - backtrace::backtrace::libunwind::trace::hae21a072c81e5842
at /cargo/registry/src/
1:   0xa5733c - backtrace::backtrace::trace_unsynchronized::h0f9b260087e46e47
at /cargo/registry/src/
2:   0xa5733c - std::sys_common::backtrace::_print_fmt::hbf1a59173a7860c3
at src/libstd/sys_common/
3:   0xa5733c - ::fmt::he1a5d6f378e506c4
at src/libstd/sys_common/
4:   0xa77d5c - core::fmt::write::hb37ae5a5e0b70623
at src/libcore/fmt/
5:   0xa50c64 - std::io::Write::write_fmt::ha24bb3f5a858327b
at src/libstd/io/
6:   0xa59974 - std::sys_common::backtrace::_print::h47b03aa1342833e3
at src/libstd/sys_common/
7:   0xa59974 - std::sys_common::backtrace::print::h2217cbc390250439
at src/libstd/sys_common/
8:   0xa59974 - std::panicking::default_hook::{{closure}}::h179f5229ea1c8e30
at src/libstd/
9:   0xa59640 - std::panicking::default_hook::h46ab82039cbc65eb
at src/libstd/
10:   0xa5a054 - std::panicking::rust_panic_with_hook::h7326c48419bc7c33
at src/libstd/
11:   0xa59c54 - rust_begin_unwind
at src/libstd/
12:   0xa75594 - core::panicking::panic_fmt::ha292e19d5ae716ed
at src/libcore/
13:   0xa753ec - core::option::expect_none_failed::h5afc8f3774fae01b
at src/libcore/
14:   0x63d1f8 - librespot_playback::mixer::alsamixer::AlsaMixer::map_volume::h7d5c6cd4990de647
15:   0x63dc74 - ::set_volume::h1824875d048eedd6
16:   0x6057d8 - librespot_connect::spirc::SpircTask::set_volume::hbcc0ef22019a3745
17:   0x5ffb64 - librespot_connect::spirc::Spirc::new::hfd339f4dcad88e87
18:   0x577890 - ::poll::hc5e7d2d1b7dbef13
19:   0x53f844 - futures::task_impl::std::set::h8f081cf0436110c9
20:   0x55341c - std::thread::local::LocalKey::with::h711a13323aafc45a
21:   0x52fa50 - tokio_current_thread::Entered
22:   0x553e00 - std::thread::local::LocalKey::with::hff64c13ccfec5327
23:   0x56020c - tokio_reactor::with_default::h7ef12e65cb103d2f

24:   0x5339f8 - tokio::runtime::current_thread::runtime::Runtime::block_on::h043f136d6b8cf48f
25:   0x5792c8 - vollibrespot::main::h02a0d49d4cc5eaa6
26:   0x560f18 - std::rt::lang_start::{{closure}}::h279cd2b7929fdba7
27:   0xa5a404 - std::rt::lang_start_internal::{{closure}}::he93bfc404849b78a
at src/libstd/
28:   0xa5a404 - std::panicking::try::do_call::h6e9e98f4078affb0
at src/libstd/
29:   0xa5a404 - std::panicking::try::h2e68d4f7f799a6df
at src/libstd/
30:   0xa5a404 - std::panic::catch_unwind::h8880a4c07cc66391
at src/libstd/
31:   0xa5a404 - std::rt::lang_start_internal::hf4ae2140248bf16b
at src/libstd/
32:   0x579d84 - main
33: 0x76d0a294 - __libc_start_main
volspotconnect2.service: main process exited, code=exited, status=101/n/a
Unit volspotconnect2.service entered failed state.
volspotconnect2.service holdoff time over, scheduling restart.
Stopping Volspotconnect2 Daemon...
Starting Volspotconnect2 Daemon...
Started Volspotconnect2 Daemon.
vollibrespot v0.2.2 cd96399 2020-10-07 (librespot 08d8bcc 2020-10-07) -- Built On 2020-10-07
Reading Config from "volspotify.toml"
[Vollibrespot] : Using Alsa backend with device: plughw:5
[Vollibrespot] : Failed to register IPv6 receiver: Os { code: 19, kind: Other, message: "No such device" }
error: error
error: error
error: error
error: error

Yep, your DAC probably doesn’t have a hardware mixer (or isn’t loading the right ALSA drivers for it). I am seeing more and more of this offlate and need to investigate why the Volumio API reports such devices have a hardware DAC, and how does it actually control volume in these cases.
Please try setting your Mixer to None or Software in the Playback settings page…

Ok, it seems it only works with the “Software” option. Although Volumio indicates that the software option results in a loss of audio quality.
Thanks a lot!!

That is true, but if your DAC (and transport) doesn’t support a hardware mixer, then there is unfortunately nothing Volumio can do…

I need to get my hands on such a USB device to figure out why the Volumio API is defaulting to the hardware DAC, when there is none…

Have there been any updates to this? I’m about to build a Pi and want to avoid having to buy a DAC HAT (or a Digi HAT). If not I guess I buy the HAT and Case.

The post from above still stands :slight_smile: Nothing can be done from Volumio’s side if the DAC doesn’t have a HW volume control/drivers for it. You can always use software volume control…