Sparky board - Volumio I2S-dac list?


I have just installed my new Sparky board. It is setup together with a Kali board.
Everything works fine - but it cant find my I2S dac chip, TDA1543.

I can choose I2S dac - but on the dac list, there are only 2 options…Piano and Piano 2.1
So playback failure, and of course no sound!

Before I had a RPI3 in this exact setup…but I would like to try/use Sparky.

How can I acces/choose other I2S DACs?

Best regards

I don’t think anyone has tested other DACs plugged onto a Kali board on a Sparky.
What DAC is it anyway?
You might want to try Piano as that is the closest one to any other i2s DAC, but I sincerely doubt it will work.
I don’t want to be rude, but I’m afraid support is an little limited here when you add non-tested hardware.
Let us know what you find out…


Thx for your reply.

I did till now used RPI + Volumio togehter with my “homebuild” TDA1543 and with direct I2S. Clean chip from old Philips CD - with 4 pcs I2S pins.
This was on RPI3 + KALI and the “Berry Nos” driver in Volumio.
Nice sound - especially when the KALI board was integrated.

In Volumio for RPI there are a lot of I2S DACs on the lists.
In Volumio for Sparky only 2!

I see in changelog that there might be kali issues in this version.
I will just wait and see development - no problem :- )

The best T_Audio

Did you try setting the I2S DAC to Piano and then connect Kali’s i2s pins to your TDA1543?
As I said, may not work but perhaps the software is generic enough to drive your DAC.
– Gé –

Yes…I tried that.
There was “faillure to open…”

I will tried usb mode with another dac, and see what happens…
Thx anyway.


Perhaps this should be in a new thread…I have problems booting sparky/volumio…

It was also a problem with I2S / Kali…long, long boot time - and lots of boots with no succes…but eventually I succeded to boot, unfornatunatly with no I2S connection, as described.

I have now dismantled the Kali board - and just connected Amanero usb board.
I connect to network with cable.

When I boot from SD micro (with the Sparky Image) I have a blue steady light - and then a led next to this slowly blinking red. Red led closest to the corner of the board…
After some time I can ip-scan and see/ping Sparky…but I cannot connect via the webinterface…nor the exact adress or “volumio.local”. Not from smartphone, not from labtop. I can see the leds at RJ45 are blinking.
From time to time the network connection goes down, resetting makes it good again.
I have tried reset, power down/on, disconnect usb, etc etc…

I cannot see any wrongs in the setup…could my board be faulty???

Best regards T_Audio