Some web radio stations no longer play, no error messages

I play web radio constantly on Volumio and for no apparent reason, the local NPR stations, KQED and KALW no longer produce any sound when I play them. Other radio stations play fine, and on another Volumio streamer in the house, running the same release of Volumio (albeit on an ASUS Tinkerboard S instead of a RPi 3B+) the radio stations play perfectly. I’ve tried explicitly giving it the URL for the station to see if it plays that way, but the output is still silent. The Volumio screen shows the banner for the site with “KQED Pledge-Free Stream”, and displays 32 Kbps, but no actual sound.
Looking in the mpd.log it says "player: played “https://streams.kqed.org/kqedradio” but no error messages. When I use curl from the command line on the player, there is definitely a binary stream of content coming through, and there’s no SSL certificate validation issues showing up from curl.
The only way I can get Volumio to play the KQED stream is to connect to it from my laptop and then airplay it to the Volumio streamer - which is silly when Volumio could just pul the stream directly.

Any ideas what could be causing this?

Has anyone else seen this problem? These stations still produce no sound and there’s not error message to be seen.

Any suggestions?

I’ve had the same issue, from doing some research it appears there’s a number of standards, also there’s the radio stations not obeying the standard anyway, so some stations work some of the time and not others.

I just don’t use them anymore, their loss

I don’t think it is a standards issue, because the stations played perfectly fine until they didn’t. And on another Volumio player in the house, using the same revision of Volumio, just a different player, the stations still work perfectly.

This is clearly a Volumio bug, so far as I can tell.

Have you tried looking at the journalctl log for any abnormalities while playing the stream?