[SOLVED] Wifi only when wired connected

Good afternoon,

I downloaded the latest Volumio Image yesterday, setup was pretty easy. Wired network became and Wifi
Via both addresses and volumio.local the webUI can be accessed.

Pi is a model 2, standard Edimax Wifi dongle, ~3 years old, worked flawlessly with Raspbian.

For further productive purpose, I plan to use Wifi only (no wired network available in the kitchen).
Now, this is where my issues arisses. As soon as i disconnect the network cable, also the wifi connection gets lost. Reboot the same, thus, Wifi only works when Ethernet is connected.
Making it pretty useless this way for me, I wanted to ask for your help, whether you are familiar with that issue, know something or can point me in the right direction. So far I tried static IP and DHCP, disabling the hotstot, searched here and with Google, but couldn’t find anything that solved my issue.

Thank you

Are you sure you actually have enough wifi signal? This setup works perfect for me with volumino 2. I had initial problems in that the Edimax’s antenna is somewhat limited.
As a test try moving the Pi closer to the access point and check if work then.
If it does, you might have to use a wifi-repeater to get a stronger signal.

Sent from my iPhone using Tapatalk


thank you for your reply, I am 100% that the signal strength is more than sufficient, I am connecting the LAN cable to my WiFi router, 30cm appart.

Also, when the raspberry is connected via Ethernet, also the Wifi Interfaces works (I can both SSH and access via the Ethernet IP and the Wifi IP Adress in my case).

As soon as I detach the LAN cable, both addresses are not reachable via webgui and SSH anymore

Plugging in the LAN cable again, brings to life again both interfaces.

Strange! What version of Volumio are you on? As I said I my setup works flawless. I wired the Pi up, enabled wifi+password. Powered down, disconnected cable and restarted. All worked.

Sent from my iPhone using Tapatalk


probably I should try to reinstall it.
Carried out some things I found in different threads, so now I can only access the GUI via port 3000.

Will do that in the evening

Yes! Reflash your SD-card

Sent from my iPhone using Tapatalk

good evening,

after endless hours of reflashing, testing, trying, connecting HDMI and what not, I found out, that it worked only from wired devices, but not from other Wifi devices (timeout). my checking my router config, I stumbled upon AP isolation, which I activated months ago in the hope of a totally different impact - that was it!

Thank you for your support, sorry for bothering you with a typical level 8 issue.

Glad you’ve found it! :wink: