[Solved] WiFi on Cubox

The kernel that is shipped on the Volumio image for Cubox (VolumioBeta12CuboxI.img) does not include the driver for the WiFi chipset used on that device. Hence the problems people have been having with being unable to configure wireless.

I have updated the image to Linux kernel 3.10, which supports the WiFi driver. You can download and install it this way:

  1. Download tinyurl.com/ks4qwtn
    This will give you the file VolumioBeta12CuboxI-kernel-3.10.img.gz

  2. Uncompress using the gzip (not zip) program.

  3. Burn to an SD card as described on the Volumio downloads page

  4. The first boot must be using wired ethernet, after which you can use the GUI to add the wireless ESSID and passphrase.

Respond to this posting to let me know how it worked for you.

Thanks Istein!

You’ve definately fixed the Wifi problem. Thanks. :slight_smile:

However, Volumio no longer recognizes my USB Dragonfly DAC. Where the old “Playback” web page used to identify my DAC and list “Dragonfly” in the Audio Output drop box, the only two options now are “imxspdif” and “imxhdmisoc”. Not surprisingly, neither results in any signal coming out of the DAC.

Though with the ethernet cable unplugged, Volumio has no problems browsing my SMB library, and cueing up music from it.

Hi Istein,

thank you for your image. Like scolley it solved the wifi issue.
But like scolley it prevents my USB DAC from working now.
May i ask you the command you have been using to add the driver to Michelangelo image ?
I am familiar with Linux, i would like to use the volume 1.2B image available on the website and add the driver myself :slight_smile:

@Michelangelo : any chance that you fix the cubox-i image to add the native wifi driver in it ? That would be amazing !!

Thank to both of you guys to support the volumio community ! This solution is a really great to listen to my music. That’s too bad that i can’t have both wifi and my USB DAC working at the same time.

Same problem here.
My wifi works well with this fix but my dac is not recognized anymore :frowning:

@michelangelo: Can you help those suffering ? :slight_smile:

Yep, I’ll release a new image soon… Sorry for this bug

IMO No apologies necessary! Last I checked, this software was free! How can we complain? :wink:

Instead, I’m grateful for what we do have. And thank you sir, for giving this your attention. :smiley:

Thank you Michelangelo !!!


@michelangelo : no need to apologize. I can understand that you didn’t think about testing the wifi if you have a wired installation at home. Not easy to make everybody happy :wink: By the way most of the cubox-i distributions i have been testing have a problem with wifi. If Volumio could get it working it would be a great achievement. Thank you for you work. I can see that i’m not the only one who appreciate it and who is looking forward your new image !

@Istein : while recompiling the kernel you might have forgotten to add some option related to USB audio (i found some info at this address http://www.alsa-project.org/main/index.php/Matrix:Module-usb-audio). If you could throw me any kind of info about how you recompiled the kernel i would be more than happy to investigate for others like me who are interested in USB DAC.

Thanks in advance to both of you

For the people interested in having both Wifi and USB DAC working with their cubox-i, Bearington posted a solution here :


I thought this would be helpful to some of you :wink:

@ Michelangelo,

I think the very same issue is present in Beta1.3 for UDOO because when I set up the WiFi connection the DAC ceased working.
Unfortunately I am not a Linux / Ubuntu etc. expert so I cannot explore possible solution but the problem seems exactly the same.
Furthermore if I try to use PuTTY I can enter volumio user but I cannot type in the password because the password field seems blocked and nothing could be typed in.
Now I am back to Beta1 which works fine with WiFi and USB DAC.


Hi Bearington,
you made my day !
Thanks for your writeup.
I have volumio, dac and wifi running on my cubox-i now.

Is this still the status of wifi/dac combination with cubox?

I’m a bit surprised to find a patched image twice the size of the original. Is the other 2 GB needed for wifi support?

Best regards,

HI Michelangelo,

in case it can help, it seems that Cubox’s internal wifi is supposed to work with 3.0.35 kernel. See this post :


There does not seem to be required anymore to move to kernel 3.10




Would like to thank lstein for his new core build. Before that everything was just more or less dead with my CuBox-i2.
( M, you are doing a fantastic job on multiple plattforms so I understand completely that even you fail sometimes :slight_smile:

I loaded the new image last night, got ethernet connection, configured the WiFi in Volumio and after that I started
indexing my music. This was ready early this morning. Turned my Cubox off.

Now turning it on, after a while I see the Volumio in the router, but it’s impossible to connect (Putty, Web interface etc…).

Turning of my router and turning it on again. Now I don’t see Volumio any more.

Reload the image again but still no success. Anyone who has a guess what’s going on ?

(( Phi

P.S. Any info when there will be a new stable release of Volumio for CuBox-i ?

Ok Guys, successfuly recompiled the kernel, now Wi-fi should work even for different adapters than mine. So, for those of you with non working wi-fi, I need you to test my new kernel before deploying into an image:

1- Connect via SSH
2- Do the following

cd / wget http://repo.volumio.org/Kernels/Cubox-i/VolumioCuboxHummingboard/VolumioCuboxikernel.tar.gz tar xvf VolumioCuboxikernel.tar.gz sync

3- Reboot

4- Check wifi is recognized with


Please paste results here and report if wi-fi is working.

Hi Michelangelo,

first of all, thank you for supporting those like me, who enjoy Volumio on their Cubox-i (we are much less than RPi users according to Sourceforge) and who cannot use a wired connection (we are even less) !

I have followed the instructions you posted and i would like to report that it seems to be working perfectly.

New kernel is loading properly on my i4Pro :

[code]Linux volumio 3.0.35-g01c6ae1 #1 SMP PREEMPT Sun Jul 6 18:51:01 UTC 2014 armv7l
/_ \ __
__ __ //\ \ __ __ ___ ___ /_\ ___
/\ /\ \ / __\\ \ \ /\ \/\ \ /' __ __\/\ \ / __\
\ \ _/ |/\ \L\ \
\ _\ \ _\ /\ /\ /\ \ \ /\ \L\
\ _
/ \ _//_\ _/\ _\ _\ _\ _\ _/
// // // // /////////___/

         Free Audiophile Linux Music Player - Version Beta1.4

             C 2013 Michelangelo Guarise - Volumio.org

Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.[/code]

Wireless adapter is now properly recognized :

[code]volumio@volumio:~$ sudo iwconfig
[sudo] password for volumio:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on[/code]

There is just one typo in your post:

tar xvf VolumioCuboxHummingboard/VolumioCuboxikernel.tar.gz

should be

tar xvf VolumioCuboxikernel.tar.gz

A last remark i had to use “sudo” to type your commands as i was logged in with the user “volumio”.

I will test my installation for a few days and report back.

Thank you for your hard work.


Thanks for the report and typo correct! Fixing!


I have the same problems with the build in WIF of the Cubox i4Pro, no WIFI.

My solution (hope temporarely) is connecting a TP-Link Range Extender (TL-WA860RE) and connected the Network cable to it and it works perfect. In fact the most extenders have a wired network connection. The nice thing of this model is that it is doing a wired connection and wifi repeater together (two functions in one).

I connected my MicroMega Mydac DAC (Euro 299,00) to the unit and to my Linn hifi. Volumio recognized MyDac. The sound is really fantastic. It sounds (in my first experiments) better than via my HP Elitebook Laptop with programs like Foobar, Jriver including the Windows Mydac driver, WASAPI/ASIO, etc.

This is really highend sound.

Volumio is a perfect solution and I’m happy to have this beatiful solution in one setup.

Many thanks to Michelangelo,

Regards Harold
(new a few days on this forum)

Sorry Michelangelo,

I was so entousiastic that I forget to see your fix. You are so quickly:-).

I will test it too.


Hi Michelangelo,

i may have spoken too fast.
Before i explain my problem let me give you some details that will help to understand the context.
Like hoeffel, i had no possibility to connect via ethernet my Cubox-i4P (that sit close to my amp) to my network. This is unfortunate as all my music library is stored on a NAS.
Like hoeffel i finally bought a little piece of hardware a Netgear PR2000 (http://www.netgear.co.uk/home/products/networking/wifi-range-extenders/PR2000.aspx) that is really full of possibilities for the price and the size (wireless router, wifi extender, wifi access point and wireless to ethernet bridge). I love it by the way. In my setup this is clearly the wireless to ethernet bridge i am using, to connect the Cubox with a wire to my network : cubox —(ethernet)—> PR2000 —(wifi)—> router —(ethernet)—> NAS

But the reason why i chose a cubox is mainly as it runs Volumio ( :smiley: ) but as well for its power efficiency (compared to any hifi network drive). So i’m still trying to get its embedded wifi working. It would allow me to unplug the PR2000.

So i go back to my problem now : the cubox was connected via ethernet when i applied your new kernel. With the new kernel, the embedded wifi is now recognized as i posted yesterday. At this point i have two network interfaces (eth0 and wlan0) connected with two different IP addresses.

[code]volumio@volumio:~$ sudo ifconfig
eth0 Link encap:Ethernet HWaddr d0:63:b4:00:2e:db
inet addr: Bcast: Mask:
RX packets:86684 errors:0 dropped:0 overruns:0 frame:0
TX packets:10944 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:23874493 (22.7 MiB) TX bytes:4196657 (4.0 MiB)

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:494405 errors:0 dropped:0 overruns:0 frame:0
TX packets:494405 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:54090228 (51.5 MiB) TX bytes:54090228 (51.5 MiB)

wlan0 Link encap:Ethernet HWaddr b8:5a:f7:82:b2:83
inet addr: Bcast: Mask:
RX packets:2 errors:0 dropped:2 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:131 (131.0 B) TX bytes:4557 (4.4 KiB)[/code]
My problem started when i tried to unplug the ethernet wire to get the PR2000 out of my setup. I immediately lost the wifi connection to the cubox : ssh connection on the wifi IP freezes and do not respond anymore, HTTP UI using the wifi IP loses the connection. After a reboot, i can not connect anymore via SSH or HTTP. The only solution is to reboot with the wire plugged to the ethernet socket and then i have both ethernet and wifi connections back again.

To be perfectly honest, after using the UI to set my network (mainly the wifi password), i directly edited the /etc/network/interfaces file.
I initially set two fixed IPs for both ethernet and wifi connections :

[code]volumio@volumio:~$ cat /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

auto wlan0
iface wlan0 inet static

I even tried with the ethernet connection retrieving its IP via DHCP :

[code]volumio@volumio:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet static

But i always get the same result. Wifi connection works, only if the ethernet connection works at the same time.
Let me know if i can provide any log or if i did any mistake while playing with the /etc/network/interfaces file.

Thank you in advance