[Solved] wicd-curses dependency problem in 1.4

Fresh Volumio 1.4 in RPi B right after boot gives me problem when trying to install wicd-curses:

pi@volumio:~$ sudo apt-get update
Get:1 mirrordirector.raspbian.org wheezy Release.gpg [490 B]
Get:2 mirrordirector.raspbian.org wheezy Release [14.4 kB]
Get:3 mirrordirector.raspbian.org wheezy/main Sources [6,066 kB]
Get:4 mirrordirector.raspbian.org wheezy/main armhf Packages [6,886 kB]
Ign mirrordirector.raspbian.org wheezy/main Translation-en_GB
Ign mirrordirector.raspbian.org wheezy/main Translation-en
Fetched 13.0 MB in 1min 8s (189 kB/s)
Reading package lists… Done

pi@volumio:~$ sudo apt-get install wicd-curses
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wicd-curses : Depends: wicd-daemon (= but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


wicd-daemon : Depends: python-gobject but it is not going to be installed

python-gobject : Depends: python-gi (>= 3.2.2-2) but it is not going to be installed
python-gobject : Depends: python-gi (>= 3.2.2-2) but it is not going to be installed

python-gi : Depends: libgirepository-1.0-1 (>= 1.29.0) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.31.8) but it is not going to be installed
Depends: gir1.2-glib-2.0 (>= 1.31.0) but it is not going to be installed

and so on.

Aptitude gives possibilities to remove mpd or to downgrade to 0.16 so these do not sound like options.

lsusb gives me ok:

Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

So which version of wicd-curses should I be installing or is there some other newbie way to config my wifi?

Why are you reintalling wicd-curses? Are you having trouble with the wifi connection?

Sorry for being unclear, not reinstalling. To reproduce:

  • download Volumio 1.4, prepare SD card
  • boot RPi to Volumio from this card, login
  • sudo apt-get install wicd-curses, and here it fails.

Used RaspyFI before and there this well documented wicd-curses approach to configure wifi did work ok.

Update: I could not get I wicd-curses installed so I configured WIFI manually, that worked so I’m ok with this. There is this possibility to use Volumio UI but it never showed me the wlan interface IP for example and I could not get the wlan configured using this Volumio web UI.

But, the original problem with installing wicd-curses remains and there may be someone else out there with the same problem.

So your post is a little confusing…did you finally get wifi working or not? I tried to use the web interface, but just did it by hand and included a lot more stuff in my interfaces file for hidden SSID, WPA2, etc. also added a route for the wireless otherwise you only have route for eth0.

Also re-arrange your interfaces file so wlan0 comes before eth0 and you will work without a wire. I dont have a network drop at my stereo…

hth whoemever :slight_smile:

wicd-curses dependency

So my issue is was that out of the box I could not install wicd-curses because of dependency issue that would have resulted in downgrading mpd. So I did not do that.

WIFI config

So I configured wifi manually (as a newbie I had to learn this at this point) editing the interface config so I’m ok with my wifi now.


I never got around the original issue, the wicd-curses dependency problem and there might be someone else seeing this same issue.



Hi Joe, everyone:

I had a similar problem:

Fresh install of Volumio 1.4 on RPi
Works great on wired connection
Wifi did not come up on its own so I assumed the steps outlined for V1.1 to set it up were still necessary.
When I try to set up the wifi (according to old guidance), wicd-curses install fails due to a dependency

In case it is useful to anyone else…there is no need to set up wifi anymore, like there was in some earlier versions. In my case I had a different issue (too embarrassed to say what it was) and when that was fixed…everything worked great.

Thank you, Michaelangelo–working great on both my Pi and Udoo.

Best wishes,

Guys, if you need to install something you need to change the repos from wheezy to jessie:

sudo nano /etc/apt/sources.list

change wheezy to jessie

sudo apt-get update

Good things happened around this issue - learned to config wifi the harder way and now also to think more about the os versions. Thanks gary and michelangelo :slight_smile: