[SOLVED] Web server for covers on mpdroid.

Hello michelangelo and everyone.

I will use mpdroid to control volumio and i know it cas use webserver to display local covers.
I try to install lighttpd but of course port 80 is already in use.

If 80 is in use and according to the fact volumio have a webGui, there is already a webserver running.

Can i use this post for raspyfi ?

raspyfi.com/forum/raspyfi-in … y-1/#p1656

Idea is to virtual link folders, so mpdroid could find covers.

Is the webserver in volumio and raspyfi the same ?


PS: michelangello, My 4 years son is found of Teenage mutant ninja turtles so each time i read your name…^^

You’ll be glad to konw that it worked.

It’s the simplest way to have covers in mpdroid. just add a link beetwen mpd folder and www folder and configure it in mpdroid setup.

omg, thank you so much for this link.
worked in seconds. Now mpdroid is really nice-looking.
Automatic downloaded Internetcovers were crappy and wrong most times.


Tip: Be sure to check the box “use large cover art tiles… [experimental]” for HighRes Covers in mpdroid.
I inserted 1000px*1000px Covers to my folders and on Galaxy S4 with FullHD display it looks just amazing!



I am glad to read that there is a solution!

But unfortunately i am to stupid for linux.

Can someone explain me how to “add a link beetwen mpd folder and www folder and configure it in mpdroid setup” ?

  • SSH to Volumio:
    ln -s /var/lib/mpd/music /var/www/covers

  • mpdroid Settings - Cover art settings:

  • check: Download local cover art
  • in Path to music enter: covers
  • in Cover filename enter: folder.jpg

Hello FauDrei!

Thanks a lot for that info!

WOW - it´s that simple - works perfect.

Let me start by saying that I am admittedly somewhat of a noob on linux… I was wondering if anyone else has had issues with setting up this web server in nginx? I am able to execute the first command above, but can still not get access to the server, either in mpod or a browser. When I try to access in a browser (volumio.local/covers), I get a “403 Forbidden nginx/1.2.1” message. Something to do with permissions possibly, I don’t know?

Thanks for the help!



I use Mpad and Mpdroid on my phone to control Volumio (installed on a Raspberry Pi) but i can’t read the local cover.
I tried to follow what i read on the forum but it doesn’t work.

I tried to do this :
SSH to Volumio:
ln -s /var/lib/mpd/music /var/www/covers
And i get the answer : "failed to create symboliuc link /var/www/covers : Permission denied.

In Mpad or my configuration is :

  • Local cover : [IPVolumio]/music
    And my music is under Genre/Artist/Album with a folder.jpg in each albuml folder. Of course i indicate to Mpad or Mpdroid to find “folder.jpg”.
    My music si stored on a NAS connected to my Raspberry.

Could someone give me the procedure to use the local cover with this configuration ?

Thanks a lot for your help



I got the same problem. When SSH: ln -s /var/lib/mpd/music /var/www/Music
I got the answer: failed to create symbolic link `/var/www/Music’: Permision denied :cry:

Need som advice :bulb:

Edit: Find an advice :smiley:
Do this:
sudo chmod -R 777 /var/www/
ln -s /var/lib/mpd/music /var/www/Music

Thanks in advance

Maybe replace music with Genre unless it’s actually Music/Genre/Artist/Album. And I’m guessing it could be case sensitive. So double check that.

ln -s /var/lib/mpd/Genre /var/www/covers

It also could be because you’re using mPOD and mDroid. mdroid needs

ln -s /var/lib/mpd/music /var/www/covers


ln -s /var/lib/mpd/music /var/www/Music

Thans a lot Bjarne it works now with your advice !

I am using version 1.5 on an UDOO and my music is on a SATA drive

I have tried

sudo chmod -R 777 /var/www/


ln -s /var/lib/mpd/music /var/www/Music

and when I cd /var/www/Music ls
I can see all of the folders of music but I get a 403 error in a web browser.

Am I still doing something wrong or is this something to do with version 1.5 on an UDOO with SATA?

I understand this works but you have to chmod 777 /var/www which is not very secure.

I did it a different way, I changed /etc/nginx/nginx.conf and added the following lines in bold

#start server1 section
server {
    listen       80;
    access_log  /var/log/nginx/access.log;
    location / {
        root   /var/www;
        index  index.php index.html index.htm;

location /covers/ {
root /var/lib/mpd/music/;
rewrite /covers/(.*) /$1 break;
try_files $uri $uri;
deny all;

The allow line should reflect your subnet, so if you are setup with a network with a gateway of that line should be

If you want to make the change to the configuration file and test then make the change and then restart nginx with
nginx -s reload

You do not have to
chmod 777 /var/www
or create the link with
ln -s /var/lib/mpd/music /var/www/covers

If everything works you then have to copy you /etc/nginx/nginx.conf file to /var/www/_OS_SETTINGS/etc/nginx so that it gets picked up on the next reboot.

Hello all,
hope you all go a god start to 2015.
I also have the problem that mpdroid does not show cover art. I have Volumio 1.5 on my Udoo quad and tried every single line as described in these posts. My musik is stored on an external hdd, my directory is: Musik/Artists/Albums.
Inside the album folder there is the cover art “folder.jpg” stored.
Hope to get some advice what else to try…
Thanks in advance, Thomas.

Please don’t do this, you will regret this!


Resurrecting this old thread. I have recently updated to volumio 2.x version. There is no www folder. So not sure what I should do now. Has anyone tried to figure this out for Volumio 2.x?


I just found out that Mpdroid and Volumio2 just works! In Mpdroid, “Download local cover art” is ticked, and “Path to music” is “cover-art”, “Cover filename” is “cover.jpg”. tcpdump on the Android device reveals:

GET /cover-art/NAS/music/Terakaft/Terakaft%20-%20Aratan%20N%20Azawad%20%5B2011%5D/co
ver.jpg HTTP/1.1

(I didn’t find any http logs on the Volumio2 device, and no tcpdump in the repos (!) )