[Solved] Volumio Stability

I have been using Volumio 1.4 for a while Rpi b wireless, and it’s driving me nuts… basically after a few days where it works perfectly it will just not boot.
I then have to reflash the SD card and reconfigure everything -

Sometimes, it will work after powering up a few times. I thought it was a loose sd card and put a piece of card under so it’s not that now.

From my observation, i think if it loses the wifi connection, it’s corrupting the card and then won’t start-up. Obviously i can’t shut down from the Volumio interface when this happens.

OK it’s working now it took 6 on/offs for it to fire up… so it’s not a corrupt card because it has just started up.

Does anyone else have this problem? Or know how i can resolve it?? it’s incredibly frustrating.

About 3 hours later and it’s dropped the connection again, the interface just has the spinning connecting thing and when i hit refresh i get - 403 Forbidden


still trying to get it started again,

Still no luck - any ideas???

Could my Rpi be faulty? SD card faulty?

Did you try to ssh into volumio and do service mpd restart

Can you try with another SD card? See this: raspberrypi.org/documentatio … d-cards.md

This realy looks like a bad quality PSU… If the SD Cards gets corrupted so quickly its because the PSU cannot supply beetween 4,75 and 5,25 volts. Probably it is underpowered. Try with another Power Supply and you’ll see that it will work. If it doesn’t is because your SD Card got damaged by this situation

Ok, after trying to get it to boot using wireless about 20 times i plugged in with ethernet cable and it booted up first time. unplugged the ethernet cable once running then rebooted via interface and booted straight again wireless only and all works.

So…, for some reason when it loses the wireless connection it’s causing an issue , I am using it in a all in one speaker, so it’s a pain to open up, unmount and plug it directly into the router via cable. and the whole idea is to have a wireless speaker.

The PSU is decent, 5v 2a I have a couple of other psus and had the same issue. I guess it might be the SD card I will get another to test, but I think it’s to do with the wireless drops upsetting it.

I think i spoke too soon, not booting up after shutting down properly via interface. Will try a new SD card and report back…

Also just tried it using ethernet cable and won’t boot… there’s some voodoo going on here but i will get to the bottom of it.

Scavenged SD card from my camera, so far so good…we’ll see how it goes

Are you overclocking? that can corrupt the SD card, in that case use USB for storage and boot instead of SD, it should not corrupt even with overclock.

which wifi-dongle do you use?
Did you installed a driver?

Well, it’s been over a week now and everything is working fine, so I believe it was the SD card that was the problem… NOT Volumio.

I wish I tried a different SD card earlier!

One thing that I have picked up on though is that software volume control using Volumio doesn’t work when using Airplay… works with Bubble upnp and library.

The volume control works on the device (iPhone) but because the amp is at full power there’s not enough fine control,