[SOLVED] Volumio 2.185 + RPi B + Creek Evolution 50

I have recently upgraded Volumio 1.55 to the latest release 2.185 on my Raspberry Pi B

The RPi is connected via USB cable to my Creek Evolution 50 CD which has a built-in DAC made of 2 x Wolfson WM8742, 24 Bit 192 kHz, double differential.

When I start playback of any tune no sound is heard. Everything was working fine with version 1.55 which makes me think the issue does not relate to DAC compatibility but rather to software settings.

Volumio’s playback panel displays 44.1 kHz | 24 bit

My audio device front panel displays 96.0 kHz

Volumio settings:

Audio output: Generic I2S DAC on both audio output and device model

I’ve been trying to play with different settings to no avail. Music plays but no sound is heard.

This is as much information as I can give. I hope someone out there will be able to help as I’d rather use the new release with all its new functionality rather than downgrading to 1.55.

Many thanks

Why enabling I2S if you want to output to USB?

Disable I2S, reboot and select your USB DAC

I have tried this previously with no result but let me try it again when I get home this evening. I will report back with details of the outcome.

Thank you for replying


Selection of the USB option in Audio Output does not work at the first attempt as for some unknown reason it automatically brings back Audio Jack after you press Save. That was probably why my previous trials failed. However I selected USB for the second time, pressed Save and this time the selection was maintained. Not sure why this behaviour, but now the system works.

Many thanks and congrats for your work guys. Volumio rocks!