[Solved] Volumio 1.5 - cubox-i4pro - Wifi not working

Hy everybody,
First of all let me say that the audio quality using volumio is excellent…

My system is composed by:

  • cuboxi4-pro
  • USB Asynchronous DAC Musical Fidelity V-Dac II (Connected through powered usb hub)
  • USB portable hard disk (WD) containing my music.

As described in the subject, i can’t connect to wifi with my cuboxi4-pro, using volumio 1.5.
In the WebUI when I try to put the data of my wifi I get “wlan0 - no interface present”.

I found this topic:
but I’m not sure that the procedure is still valid for 1.5 release; I tried to put the following code accordingly:

root@volumio:/# cd / root@volumio:/# wget http://repo.volumio.org/Kernels/Cubox-i/VolumioHummingboard/VolumioCuboxikernel.tar.gz --2015-02-10 08:56:21-- http://repo.volumio.org/Kernels/Cubox-i/VolumioHummingboard/VolumioCuboxikernel.tar.gz Resolving repo.volumio.org (repo.volumio.org)... Connecting to repo.volumio.org (repo.volumio.org)||:80... connected. HTTP request sent, awaiting response... 404 Not Found 2015-02-10 08:56:21 ERROR 404: Not Found.

Doing ifconfig and iwconfig i obtain:

eth0      Link encap:Ethernet  HWaddr d0:63:b4:00:7b:86
          inet addr:  Bcast:  Mask:
          RX packets:695 errors:0 dropped:0 overruns:0 frame:0
          TX packets:872 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:154067 (150.4 KiB)  TX bytes:179074 (174.8 KiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3476 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3476 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:357025 (348.6 KiB)  TX bytes:357025 (348.6 KiB)
root@volumio:/# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

Do you have any suggestion?
Thank you in advance for your help

You don’t need to apply the above procedure for 1.5.
I suggest you to use a clean system, boot and wait at least 2 minutes before configuring your wi fi network.
Is it WEP or WPA?

Thank you for your prompt reply!
The network is WPA2.
What do you mean with clean system? Re-install the volumio image in the microsd?


It works!
Thank you once again…problem solved