[Solved] Using Creative X-Fi SB1090 DAC with Volumio


I am wrting because I am a little noob and I can’t make my DAC working with Volumio. I would be glad if anyone can tell me if there are any chances of setting it together.

My device: Raspberry Pi B
Volumio version: Lastest, 1.55
DAC: Creative X-Fi SB1090 (with remote)

At first attempt when I connected DAC to RPi it probably couldn’t handle simultaneous WiFi connection (through USB dongle) and DAC. Maybe not enough power. So now I have connected DAC using active USB hub, and it was detected as S51 (i see it in “Playback” tab on WebUI).
But I don’t know what to do next because there is still no sound :frowning: I tried changing Hardware/Software Mixer, but it didn’t help.
Thanks in advance for any help!

PS Sorry for my bad English :wink:

Mmmm… I don’t know how to help, really not much information here.
Try this:
Turn on Pi, with USB DAC attached.
Then, try to play anything. Do you have sound?

If not, connect via SSH and check the volumes with


If you can post a screenshot of what you see in alsamixer

Ok then. Just tell me what information do You need and I will provide it :wink: I am noob when it comes to Linux :slight_smile:
I turned on Pi with my DAC attached several times and it didn’t help :frowning:

I can’t change volume in alsamixer. Here’s what I see:

I don’t know why and how is that possible, but I have just heard startup sound from my speakers. The only thing I have done was running alsamixer over ssh. I didn’t reboot Pi. And it was running half an hour before that.
WebUI is working. AirPlay not.

After 2-3 minutes: AirPlay showed up on my iPhone. When pressed play there is no sound. Maybe few seconds of little noise (but not loud, just radom noise for second or two).
Still same view in alsamixer and no audio though USB DAC.

After next minutes (did nothing, Pi plugged as it was): I heard this noise again. It appears to be sound that come from DAC when I play music though AirPlay. I assume that DAC is working but not as it should :slight_smile:

Thanks for your fast reply!

PS I shoud select ALSA or S51 audio output? Volumio somehow changed S51 do ALSA itself. That noise I described appears no matter if ALSA or S51 is was selected.

PPS Selecting “Fastest Sinc Interpolator” didn’t help.

ALSA is Pi’s internal sound card. So you should use S51.
From what you tell, the system is not working properly.
To me it definetely sounds like an insufficient power supply. Do you have another one? Try with another power supply and let me know!

What power supply for Pi do you recommend? Current set was 700 mA for Pi and 500 mA for DAC, but it could be insufficient, you are right.

I can supply Pi with 1A, but I don’t have other (other than 0.5 A) power supply for active HUB that powers DAC now. But do I need this hub? Maybe well-powered Pi would handle USB DAC and WiFi dongle at the same time? If it will than what is recommended amperage of power supply?
I feel really dumb right now :unamused:

Trying success with 1A power for Pi and 0.5 for hub that powers DAC. I am more confused now because Pi can be powered from USB only - when connected DAC it turned on without connecting that 1A power supply…

Pi gets voltage also the way back, from its USB, but is not an ideal solution. 1A PSU for Pi could be barely sufficient for USB wi-fi and DAC…

Does it work this way?
If not, use in conjunction with powered USB hub…

It worked with 1A power supply now. I am surprised how easy that was and ashamed of it :blush:

And I just found 2A power supply in my house, so I will use it :wink: I just haven’t touched Pi for more than 2 years and I even forgot that 700-1000 mA is minimum for it.
Sorry for taking your time for such “problem”.

I’m glad it worked and I it will you can be sure that I will donate! :wink:
I used SqueezePlug before and Volumio kicks it’s ass!

PS Is it possible to use remote for my DAC somehow to control Volume?