[Solved] Update to V3 from 2.917 failed

Volumio Information

Volumio Version: v2.917
Hardware: RPi 3B
DAC: I2S Rpi dac

Tried to update to V3 this evening (done it countless times on V2 to V2 updates).

Using the Android app. Latest version from playstore.

It started off checking and then went to Creating Backup, which stuck on 14% progress for over 40mins.
No activity on the RPi red/green read/write light. Just stayed red.
I started another app session from a second phone. This opened and connected.
Looked normal but then just gave a completely white screen. Nothing could be done about that. Restarting the app made no difference.

With RPi staying on solid red light, I powered down.
Powered up again, app connected and I was directed to do a full setup of V2.917.
Language, network, Qobuz etc
I was still signed into Virtuoso though.

Once all set up, I could play Qobuz music again.

My NAS settings were lost. I only use this with perhaps 50+ tracks, as back up if Qobuz is down (never is really).

Please advise. I’d like to update to V3 but don’t want the hassle of messing with SD cards and cmd windows.

Volumio team recommended a Factory Reset (I reckon that was what happened anyway after the fail).
Once performed the update to V3 went perfectly smoothly.