[SOLVED] UK BT Router Setup

Hi All.

First post here, and I am not very computer / pi / network literate.
Hopefully I have discovered something that once resolved may be of use to people.

Hardware is a Pi 3 version B, a piano 2.1 DAC and a Kali. Router is the BT Broadband hub 5, which is pretty common in the UK.
Hardware arrived at my work. Assembled, Image written to a SIM all as per the download guide. Pi disconnected and moved to the router, powered up and ethernet cable plugged in. Volumio visible on the router, address typed in on the command line and WIFI set up. All fine. Ethernet cable disconnected, Piano 2.1 player set up and a reboot carried out. Browsed and loaded spotify plugin and tested streaming. Browsed and tested web radios. All working perfectly connected to a pair of active Tannoys.

Took the Pi home, plugged it into my router, which is an identical BT hub although a home not a business one. Network setup works perfectly. I can change settings and restart from the UI,but I am unable to browse plugins, or web radio.

So between one location and another I have a problem. Both hubs identical pieces of hardware. Both are in a standard setup, nothing exotic has been done by way of IP or security settings. I took everything back to work, formatted the SIM. reinstalled and tried again. Same result. I then formatted again, but did the first boot and network connection at home. Still the same result.

I am guessing this is a network issue. Volumio is unable to communicate with the outside world at home, yet has no problem at all at work.

Anyone care to point me in the right direction as to where to look for the setting responsible? I have a feeling this is very simple.

Cheers - Chris.

I think the issue was related to dhcpcd overwriting your router setting… This has been solved in the new release which will be released hopefully soon.
If you want to try our fix try to apply the fix suggested in the last post here:
internet-access-t5383.html

Thank you - I will see if I can work through the fix.

Is there a way that I can prove that this overwriting is in fact happening?

Regards: Chris.

A whole evening trying to negotiate the directory structure. I kid you not. I am now versed in the cd and ls commands.

I eventually found the directory etc/hostapd/hostapd.conf

So err… what do I do now? Edit it so it looks the same as the text in macmpi 's post? If so, in really basic steps - how do I do that? This was screen and keyboard plugged into the pi.

I have no idea how you guys are connecting to the pi and doing this using another device :smiley:

Cheers - Chris.

This is how you can use a PC to connect to your PI in a few steps:

  • download a program called ‘putty’ and install it
  • find out what ip address your PI has (there is a package on the net called ‘ip scanner’ which may help, otherwise check your router for the list of connected devices
  • using putty, open a session with the ip as hostname
  • when prompted for it, enter user and password
  • you’re in…

Hi Chris, you can remotely access your Pi from another device by using ‘ssh’ … this can be done directly from the command line in Linux or using the program ‘putty’ from Windows.

ssh volumio@192.168.x.y

Once you are logged in you can enter commands as though you were directly connected to the Pi with a keyboard and monitor.

macmpi essentially said in the last post to try typing:

sudo mv /etc/resolv.conf.head /etc/resolv.conf.tail

followed by a reboot:

sudo shutdown -r now

Good luck

Thanks - very helpful.

I was playing with this on a MAC and used Terminal. Thats where I got stuck. I got a message ‘Authenticity of host*192.*could not be established’. A load of stuff about an ECDSA key etc which I don’t understand. So not wanting to defy human nature, I was not sure so I typed yes :smiley:

That did let me connect - sort of, but I was confronted by a request for password and a key symbol. Couldn’t seem to do anything - type a password or anything else. I gave up at this point and spent a while trying to figure how to remove that IP from its folder.

I’m interested to know what am I doing wrong?

Sorry - real ground zero stuff I know.

Success.

Took a windows laptop and downloaded Putty onto it. Followed the instructions given by you both and connected to the Pi.
If anyone is reading this as a reference, you will get a prompt about connecting to the server 192. blah. There is an option to connect just once. Type in the Volumio user name and password, and you are indeed in.

Typed the command as given above - (mind your spaces). Hit enter. To a newb like me that doesn’t seem to do anything. Don’t worry - it has. Then typed the reboot command given above. Opened Volumio.local in a browser and could immediately see something was different. I browsed and downloaded the spotify plugin, set it up and it all worked perfectly. Bowsed web radios etc. Again - it all works and I have playback. Performed a shutdown and power off reboot. No problems.

Thanks all for your patience and help: Chris :smiley: