[Solved] UDOO with USB DAC problems: no sound in Volumio

You could also try restarting MPD when it stops playing.

service mpd restart

The mpc stop command works, it give the volume % and some services and no errors. Music stops playing.

BUT: a reboot from ssh and Volumio does not work anymore. It plays the song (timers runs) but no sound.

I just unplugged it now and re-plugged it back in. Twice… Still no sound.

Back to the image is the only way I know how to fix it.

@Michelangelo: I am happy to try more of this or gather logging - would be good if it can be solved!

SOLVED (but don’t exaclty understand why…) by creating an ALSA config file:

nano /etc/asound.conf

And in that file, I have put a default setting (with USB sound devide name, not number):

# use Peachtree X as default device
# (from /proc/asound/cards)
pcm.!default {
    type hw
    card X
ctl.!default {
    type hw
    card X

No changes in mpd.conf. That one says (same as always):

audio_output {

                 type           "alsa"
                 name           "Output"
                 device         "hw:2,0"
                 mixer_control  "PeachtreeClock Selector"
                 mixer_device   "hw:2"
                 mixer_index    "0"
                 dsd_usb        "yes"


So there must be something strange in the default settings. Maybe the mixer index should not be “0”? Anyway, my issue is solved with the default in the newly created asound.conf file!

I have experienced almost the same problems as user “haraudio”. Volumio lost connection with my Auralic Vega USB 2.0 dac if the dac switched the selected input. This happened on my Raspberry pi 4.

To get any sound output from volumio to the dac again I would have to reboot volumio to get it reconnected. After adding the above described config file, (/etc/asound.conf) only exchanging the X with my dac name (A20) it worked. Changing the dac input or even restart the dac still keeps the connection. Thanks!

This solves my issues with getting volumio and my dac staying connected. :slight_smile:

read through this thread to try to get my setup to work

  • rpi3
  • peachtree nova65se DAC and AMP

what values do you configure in UI for audio output

Output Device: Peachtree Audio 24/96 USB Inter
I2S DAC: Yes
DAC Model: ?

I dont quite know what to pick there since none of the models exactly match?