SOLVED: Spotify Connect "Can't play this right now"

Installed latest version of volspotconnect2 v0.4.0 (also tried volspotconnect) using volumio 2. I was able to control Pi 3 using this plugin all day yesterday. Today, my devices show up in the devices list as “Can’t play this right now”. My devices will appear/disappear from the list normally, but cannot be selected. I’ve reinstalled the plugins, and rebooted, but nothing seems to work. I saved the output from the PI while enabling/disabling the plugin:

For some reason, Spotify Connect does not work when playing podcasts! When switching to an actual song, the devices were available again! :laughing:

1 Like

I just experienced this from my iPhone 12 Pro!
Just spent over an hour restarting, reconnectiong every thing.
Thank you for the tip!

What version are you all using? Podcasts (well some of them) are supported in the newer versions…

I am experienced the same issue with 2 different Pi’s running 3.233.

A particular podcast would not play - Robert Plant Digging Deep.

On the Spotify app on android, “Can’t play this right now”

On iOS “Playback restricted”

No problem casting the podcast to other devices such as an AV receiver.

Other podcasts and music all ok.

A licensing restriction?