[Solved] spotify choppy sound

Hello, I recently enabled Spotify support in Volumio. The sound drops out every now and then and I can’t figure out why. Nothing else significant is using my internet connection, and I don’t have this issue when playing local music. I documented the times that the issue is occuring (let’s call it a “blip”) and there is no discernable pattern to the moments of silence (which may last as little as a quarter second or up to a second or two). The blips also don’t appear to correspond to the times that spopd is downloading song parts from spotify (as reported by spopd.log). Here’s what I have so far:


I also disabled high quality audio to see if that helps, and it didn’t, although that may be because /etc/spopd.conf remains unchanged after modifying this setting (I assume it’s supposed to set high_bitrate = false per https://github.com/Schnouki/spop/blob/master/spopd.conf.sample).

Any idea what might be going wrong or how to troubleshoot further? I am using Volumio 1.5 on a Raspberry PI with a USB DAC (and yes I have forced USB 1.0 due to static issues with USB 2.0). Thank you!

I just tried manually setting high_bitrate = false in /etc/spopd.conf and got the same result.

I’ve been chasing the same issue with no luck. I’m thinking it might be a CPU usage issue. My MPG123 process runs at 90 +%.

It doesn’t appear to be a CPU issue for me. spopd is running at between 7 and 14%, and nothing else is using much CPU at all. I also just recently switched from a USB DAC to a HiFiBerry and get the same result. The load average is only 0.25 or so while spotify is playing.

Any ideas what might be going on? I’ve continued to watch dmesg and the logs and don’t see anything telltale happening when the playback goes silent temporarily. Quite frustrating…

A slow SD card or insufficient cache space often causes this. Let me know if fixing either solves your problem!