[SOLVED] Something wrong with HiFiMeDiy U2 Async DAC

Hi ev’rybody

I’m experimenting a strange behavior with Volumio and the HiFiMeDiy U2 Asynchronous DAC.
When I listen to 96/24 files, everything sounds perfect. But with 44/16 files or during AirPlay, there are lots of pops and glitches.
I’m using the WiPi wifi dongle to stream the FLAC files from my NAS.
Any ideas on what’s going on?

Which version are you using?

If you’re using the Beta1, just apply this fix and please let me know how it goes:


Hi, thank for the answer.
Unfortunately I’m using version beta 1.1, conversion rate is already set to 44100… :confused:


Same DAC here, and same problem: 96/24 FLAC plays well but 44/16 FLAC sound horrible. I’ve played some FLAC files from RAM to discard network issues but the problem remains… until you convert the FLAC files to WAV. Then everything sounds perfect!

I’m not going to convert all my music to WAV, of course, but perhaps this give us some hint. A library problem, perhaps? Could you try to convert and play some FLAC files?


I have the asynchronous model with sa9023 usb chip and works great on volumio v1.1

Sent from my Nexus 4 using Tapatalk

Hi all.

I think it is a power issue. I’ve attached the DAC to a cheap passive USB hub and the hub to the Raspberry Pi, and everything sounds ok: WAV, FLAC, 44/16, 96/24…

I’ve tried with a cheap phone charger and a 10W iPad charger: if attached directly, the DAC plays with pops and small pauses with both adapters. Going through the hub it works well with both adapters too. The U2 is power demanding, so using a powered USB hub is perhaps the best solution.

Hope this helps!

Hi Albert, thank for your suggestion, I’ll try to use a hub and post what happens.

Well, it took me two months to try out, but I eventually succeeded!
Using a powered USB hub mad any glitch disappeared.
It was definitely a power issue!