(Solved) Screen resolution wrong after upgrade


I upgraded to the latest release, today Sept 11, from the previous release using the automatic upgrade button.
Upgrade completed but after a restart the image no longer fills the 840x480 waveshare LCD. It looks like 640x480 with the right 1/4 of the screen blank, although the touch screen thinks everything is normal.

Wiped and started new install, same thing. Even the volumio splash screen during boot and shutdown is no longer in the centre, but shifted left.
The previous version 2.5xx it just worked properly after installing the plugin.

Any ideas?

What is the exact model of your Waveshare display and how is it connected (SPI, HDMI, USB)?

If you are using a Raspberry Pi and the display should need modifications of the /boot/config.txt these would have to be applied again after the (each) Volumio update.

I suspect this is a kernel related thing. We recently updated the PI kernel to allow for use with Raspberry PI 4. This kernel, more than others has brought various issues (no audio on jack, display resolution etc)

Ah, ok. Thanks for the info :slight_smile:

EDIT: I had to add an hdmi_mode=87 for this screen into config.txt and its good now. The previous version of volumio (and its kernel) worked without that line.


Great you solved it! :slight_smile:

Could you try replacing hdmi mode with hdmi_safe=1 ? and let us know?