[SOLVED] Raspberry PI Rev1 with I2S Audiophonics I-Sabre

Hi, everyone!

I’ve just bought the DAC in subject, an Audiophonics I-Sabre
audiophonics.fr/en/kits-modu … -8962.html
I own a Raspberry PI Rev1, that doesn’t have the handy I2S connector. So I’ve followed this topic
i2s-raspberry-rev1-256mb-ram-t470.html
and soldered the wires on the resistor pads (Raspberry PI side) and on the pins (DAC side). I’ve double checked the connections and the soldering, and everything seems ok (continuity from resistor pads to DAC pins, no shorts between resistor pads, no shorts beween pins). Precisely, I’ve connected the I2S signals as stated in the above topic, while I’ve connected GND and 5V to the GPIO pins (pins 6 and 2). Also, as read here and there, I’ve connected the MCLK pin to ground (maaany doubts about this).
I’ve started the Raspberry PI and accessed the web interface to made some tests (rebooted after every driver set):

  1. I2S driver not activated: sound from RPI stereo connector, no sound from DAC (obviously…)
  2. Activated HiFiBerry I2S driver (looks like the one to use with sabre, given forum posts) : NO sound from RPI stereo connector, no sound from DAC
  3. Activated HiFiBerry+ I2S driver : sound from RPI stereo connector, no sound from DAC
  4. Activated RPi-DAC I2S driver : sound from RPI stereo connector, no sound from DAC
  5. Activated Generic I2S driver : sound from RPI stereo connector, no sound from DAC
    So, no luck…
    The result of test 2 in quite interesting; is the configuration I supposed will work, and even the normal output remains silent, instead.

Any hints about how to let it work?
Anyone had any experience with this DAC baord?

Many thanks!
MIX

– EDIT –
I’ll summarize the hints that I got in this thread, if there is still some living beings interested in RPi Rev 1.
Note that I managed to use a different DAC with respect to the one in the title, while still based on es9023 IC.
The trick was to remove pull up/down resistors from DATA, BCK, LRCK nodes (see here https://volumio.org/forum/i2s-raspberry-rev1-256mb-ram-t470.html), that are R8/R10, R9/R7, R3/R5.
To use this DAC you have to select Hifiberry DAC drivers on Volumio web interface.
RPI-DAC.jpg

Try hifiberry driver

Uhm… already done it (test 2).

Check here again for mistakes i2s-raspberry-rev1-256mb-ram-t470.html

Ok, I will re-re-re-check the wiring.

In the meanwile, as a personal research, I’ve confirmed that the info in the mentioned post are correct, given the schematics revision stated here
http://elinux.org/RPi_schematic_differences
and more precisely in this image
http://elinux.org/images/3/35/Schematics-diff-page2.png

About the MCLK signal, is it right to connect it to GND? What is this signal for?

You don’t need to connect mclk, because dac has its own clock on the board.

“You don’t need to connect mclk” or “You should not connect mclk”? In other words, is it possible that connecting MCLK to GND will cause some problems?

Well, I reviewed my wiring again, but it seems OK. There are no shorts and each resistor pad is connected to the right pin. The DAC board receives the 5V power from RPI.
I’ll try to make a test with an oscilloscope, to see if there are actual signals sent to the board. It will take a while…

Here am I.

Oscilloscope update!
The I2C signals reach the board (I’ve measured them on the white expansion connector). BCK is 2.8 MHZ. DATA switches with BCK. LCLK is 44 KHz.
I’ve made a screenshot of BCK/DATA

All signals switch between 0V and 3V3 (they are scaled in the graph).
The three signals reach the ES9023 pins, too.

All ES9023 pins status during playback:
BCK: 2.8 MHZ
LRCk: 44 KHz
SDI: switches according to song and BCK
DIF: 0V
AVCC: 3V3
VREG: 1V circa
AOUTL: 0V (!!!)
AOUTR: 0V (!!!)
CP: 0V
CN: 0V
NEG: 0V
AGND: 0V
MCLK: 50MHz
DGND: 0V
MUTE_B: 3V3 (active low, so a logic ‘1’ is ok)
ZD: 0V

Everything looks ok (at least to me…).
Besides the fact that nothing can be seen on the RCA output… Ideed, AOUTR/AOURL are always 0V.
Also, I’ve tried changing the playback “Audio output format” settings in Volumio to 24 bit / 192 KHz (talks about this in the board specs, and MCLK table in the datasheet ES9023 seems to suggest an higher frequency, too). The input signals change accordigly (i.e. LRCk switch @ 192KHz), but still no output.

Any idea?

Side note about the fact that in test 2 (HifiBerry I2S driver enabled) I got no output from the Raspberry stereo jack. This behavior is due to the fact that, enabling the driver (and rebooting) Volumio automatically set “Audio Output” to sndrpihifiberry in playback options. Selecting ALSA the audio can be heard from stereo jack as usual.

Try older volumio version, because I think the new kernel version realizes that the rpi is old version and has no i2s pins. I have installed picoreplayer on rpi 256mb ram and it doesn’t let me to choose i2s, only analog and usb.
And let us know, because I have the same problem as you with old rpi with i2s hack and new volumio and picoreplayer.

Well, Volumio let me choose an I2S driver, and generates the signals, too.
BTW, any suggestion about a version to test?

Try 1.51 here sourceforge.net/projects/volumio … %20PI/1.5/

No luck with an older version. I tested RuneAudio, too (can I say this here :slight_smile: ), but nothing new.
As said, all signals reach the board, and the DAC component, too. So I don’t think it can be a software problem.
I’ve contacted the Audiophonics staff to have some tech support.
In the meanwhile, if anyone came up with good hints, I’ll be glad to hear.

hello,
Maybe what I 'm going to say is stupid, but have you try with a other power supply ? Espcially if you use a smartphone psu… (or maybe you discribe it before).
(For one of my project I use a audiophonics DAC base on 9023 http://www.audiophonics.fr/fr/kits-modules-diy-dac/audiophonics-dac-sabre-es9023-i2s-vers-analogique-24bit192khz-p-8396.html with RPI B 512Mo and I use Hifiberry driver. Ok nothing new for you… :neutral_face: )

I’ve checked again my wiring, and data and bck were mixed, corrected everything and its working now. Check again wiring from the post I gave you on this forum.

What I want to say, is to check if your psu is able to delivers enough current to power the rpi and the dac…

@balbuze, not at all a stupid question! At work, where I’ve tested with the oscilloscope, I’ve used a crappy usb power adapter, with 1A maximum current. At home I have a better one, that outputs 1.2A maximum current (but no audio at home, too). I can test with a lab power supply at work; this way I can check the actual power consumption, too. Awfully (luckily!) it’s friday, so I have to wait at least monday to test.

@birca1987, I didn’t get your post… Are you saying that the wiring stated in your thread is wrong? I’ve checked it with the schematics and it looks ok. Also, wasn’t your setup already working?

In the thread the wiring is ok, but broke the wires some time ago and had to start from scratch, this time is under the board, so mixed the two signals, today rechecked and got it working.

Tested with a lab power supply.
The RPI consumption with I-Sabre is around 450mA, so the power suppy I’ve used so far are enough. The lab power supply is more stable and all, but still no output…
Side note, I’ve noticed from RPI schematics that a 1A limiter is placed just after the USB power connector, so no more than 1A can be drawn from the source, anyway.
Will wait for answers from Audiophonics crew…

I had the same problem as il_mix with an Audiophonics DAC with a a 256MB Raspberry Pi v1 without the P5 sockets.

When wired up as described in this thread I could see the signals on my oscilloscope, but nothing from the DAC.

The solution I found was to remove resistors R8 R10, R9 R7 (if fitted), R3 R5

Refer to the schematic at http://elinux.org/images/3/35/Schematics-diff-page2.png

Without those resistors I got a nice clean signal and the Audiophonics DAC burst into life…