[Solved] Raspberry Pi B+ eth0

Hi Guys - I installed Volumio on the new Model B+. The B+ uses a new network / USB chip, the LAN9514 rather than the LAN9512. Unfortunately Volumio can’t find eth0 when installed on the new B+ Raspberry Pi. Is there an easy fix for this or will an updated version of Volumio be released to address this issue?


My Raspberry Pi B+ with Volumio had the same issue. (USB devices recognized, then disconnected)
I upgraded the kernel to 3.12.x and it worked.
Probably the kernel from Raspbian will work.
(I rebuilt the kernel by myself, so I didn’t try Raspbian’s kernel.)

I also look forward to the new Volumio addressing this.

I’m having the same issue. I flashed Volumio 1.4 to my SD card last night, hoping I’d be able to get it running on my new B+. It boots fine (makes it to a login prompt) but it doesn’t seem to recognize anything on the USB ports, and won’t bring up the ethernet interface.

Seems like the current version of Volumio simply doesn’t have the drivers for the B+'s new USB/Ethernet chip. Hopefully we can get a prompt fix for this.

Sina, how did you go about updating your kernel like that?

Hi Niyeaux,

Chances are searching the Internet for ‘rpi-update’ would help you.
$ sudo rpi-update
This will update your RPi’s firmware.
(Note that possibly, this would break your system, resulting in re-installing volumio.
I didn’t do this. I built the kernel. c.f. elinux.org/Raspberry_Pi_Kernel_Compilation
This is a tough thing…)

rpi-update/ rpi-upgrade do not work. I read about this being suggested to update the Kernel in order to recognize the new USB chip, so I loaded Volumio 1.4 on my Model B and applied those changes. Moved the SD card to my new Model B+ and it does not work. Ethernet blinks for a second and then goes dead. Without USB and ETH working there is pretty much nothing you can do!

Looks like we’re SOL until Volumio ships an update. It’s a bit disappointing that they haven’t already. RuneAudio and Pi MusicBox are both working on the B+ already. I think I’m gonna switch over the RuneAudio for now, at least until Volumio ships an update.

see a post i made to get it working fairly easily:

this is quite dirty, but itll get you running until there is an official update.

There is an official update, lol (I always wanted to say that)



I just tried with a B+ and while I got an error using 1.4 I only get a black screen using 1.4.1 I don’t have ethernet so I can’t try to ssh until I get to configurate wlan0. Has anyone had this issue getting only a black screen? I do not get any text up whatsoever when booting up, When I boot with 1.4 it will display some text until getting a failure and freeze the console.

You are using the same screen right?
Can you check your Led on the Raspberry? Power Led and System Led