[Solved] Rasp b+ and HifiBerry Dac analog + errors


I installed and configured my HifiBerry analog + with Volumio 1.5 on Raspberry pi b+ with power supply
Aukru, Model : AP12003UV, Input 100-240VAC0.3A 50/60Hz, Output:5V 2A

1/ I tried all type of songs, with resluts :frowning: :
a/ Studio Master FLAC 24bit = songs are at a very strange pace, impossible to listen
b/ Studio Master (192) FLAC 24bit, = songs doesn’t play, and generates errors described below
c/ CD Quality FLAC 16bit = songs plays well but impossible to change Volume in Volumio Web interface
d/ MP3 MP3 320k = songs plays well and I am able to change Volume in volumio

songs versions are from here:
dealabs.com/gratuit/24-morce … mbre/88003
or directly here linn.co.uk/christmas (till begin of january 2015) by creating an account you can download 4 versions (Studio Master FLAC 24bit, Studio Master (192) FLAC 24bit, CD Quality FLAC 16bit and MP3 MP3 320k) of the same song (there should be 25 songs in total), and :

2/ the raspberry is getting in error = nothing works anymore :frowning:
3/ on the terminal, there are errors such as
I/O error -110 mmcblk0 …
4/ I got lots of difficulties to halt the raspberry pi, it takes 10 mins.
5/ if I reboot my Raspberry pi, I got the same “mmcblk0″ errors
6/ on another forum (maikel.pro/blog/this-might- … pberry-pi/)
I followed the Win7 instructions and I could re launch fine the raspberry pi,but

a/ I don’t understand why playing Studio Master FLAC 24bit or Studio Master (192) FLAC 24bit crashes Volumio/Raspberry pi,
b/ why it corrupts also the filesystem
c/ I installed on another SD card, results in same errors
d/ I allready wrote on HifBerry Forum, they asked to write you.
it might have something to do with MPD with specific kernels. should I downgrade?

thank you a lot for your feedback



Try v1.51. There was some issues with high res files on 1.5.

Check the forum posts there is plenty about this type of problem,


Hi Kevin,

thank you, this time wtih version 1.51 HiRes audio is working fine!
The only issue I got is that I can’t change volume, it is always at 100%. When I am listening to and Amp it’s not such a problem but I generaly plug it in directly to my earphone :frowning:
any chance you can help me ?

thank you in advance

Best regards,


Enable Hardware mixer and hit apply settings. This will do the trick.
If it doesn’t work, use software mixer.

PS: where did you downloaded 1.5 ? The download section now points to 1.51 …

Let me know


Thank you, I put it to SOFTWARE and now it seems to work fine!
I got to download 1.51 version on github as I only had 1.5 since October.

Another issue: Wireless + hidden SSID
I just bought an TL-WN823N Wifi adapter (an Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter) as I want to put my Volumio box far from an ethernet RJ45 plug,

I was inspired by : http://volumio.org/forum/wifi-and-netgear-n150-t112-10.html

My /etc/network/interfaces looks like

[code]auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

#allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf[/code]

and my /etc/wpa_supplicant/wpa_supplicant.conf looks like :



Wifi seems to work, but as soon as I unplug the Ethernet RJ45, the Wifi connection doesn’t work :frowning:
do you know what did I miss ?

Thank you very much for your assistance

Best Rgards,