[SOLVED] Pi continuously resetting since update -> power?

I recently updated my Volumio instance. Since this update, my Pi is continuously hard resetting during the late boot process (no specific stage, feels somewhat random, can be delayed by repeatedly pausing the boot process using scroll lock).
It appears that this happens on high CPU load due to power issues, since the attached LCD occasionally displays the yellow electric flash symbol in the top right corner (didn’t do that before the update). I tried disconnecting the LCD, then Volumio boots up completely but is still unstable/the problem is just postponed: when I start using the web interface it quicky shuts down and the Pi reboots.

My system:

  • Raspberry Pi 3
  • Hifiberry AMP+
  • Waveshare 7" LCD
  • 65W power supply that connects to the AMP+ and powers Amp, Pi and the LCD.

I now tried three different versions/images, flashing the original image onto the SD card:

  • Volumio 2.129 2017-03-23 works stable
  • Volumio 2.175 2017-05-16 does not work (hard reset at late boot stage)
  • Volumio 2.815 2017-06-03 does not work (same)

Do you have any ideas for further troubleshooting? Looking at the changelog I saw changes to the CPU governor. Could this be an issue?
Unfortunately, I don’t have a second power supply at hands, however, since the old distro was working fine over months I doubt that this is the issue.


It might well be a power issue.
You can try this:

  • Connect via SSH asap
  • Type this:
    sudo echo ‘GOVERNOR=“powersave”’ > /etc/default/cpufrequtils

save and reboot. Does it work now?

Indeed, this seems to work. Very interesting. This also explains why I had the feeling that my Pi was so slow all the time - it was constantly running on 600MHz…
I will invest in a new power supply and see whether the ondemand governor works then.

Thanks for your help!

I tried another power supply of different brand. Same behavior: Only with the powersave governor I get a stable setup. As soon as I switch to ondemand or performance, it randomly resets.

I suspect that either the Pi or the HifiBerry Amp is broken? Or could it be yet another issue?

Can you feed the raspberry PI trough a different power supply than the AMP?

I certainly could try that. Is parallely feeding both the Amp and the Pi safe?

I took the chance and it works. I assume the Amp is to blame then.
Thanks for all your help, it’s very much appreciated!