[Solved] No luck with USB Wifi adapter from Monoprice

Hi all,

Bought this cheap dongle from Monoprice due to its claimed Linux support.


The driver script seems to claim it’s a Realtek.


Tried to see if it was recognized out of the box, no luck. Even ran the install shell script, and no luck there. Tried to set the network name/login in the GUI via ethernet, and then reboot with just the dongle and no luck.

Not really even sure if this this might not be defective? I thought I read somewhere these had Kernel support. Any thoughts would be appreciated.

For me also no luck with the wifi dongle.

Even it is another one you’ve bought… driver is rtl8188C_8192C_usb_linux.

Please give us some hints to look for… i am not familiar with rpi… As i really need the cable one which it is running now.

Mine is exactly the same as in this post.


HAHA… Mine is working…

I did two things…at the same time. So i dont exactly what did the trick.

I have updated the drivers by this tutorial.

raspberrypi.org/forums/viewt … 28&t=62371

I removed a line at network/interfaces.

learn.adafruit.com/adafruits-ra … cidentalis

I dont know the exactly phrase which i deleted.

But there was something like “Wlan power off”
I thought that was not a good command to have…

And set this command in the file “allow-hotplug wlan0” which was not present.

And now its working

Well &$*(%!!! Can’t tell you how much I have tried, and how much time I have spent on this.

Wackid’s solution worked for me.


On Cubox-i, the kernel seems to be version 3.0.35+ #1. So this solution doesn’t work! :frowning: