[Solved] NAS Problem: WD MyBookLive

Hello

I decided to give Volumio a crack on my Raspberry Pi as the instructions for installation appeared straightforward.

No issues getting Volumio up and running however, I am unable to mount my WD MyBookLive, I constantly get a red cross next to it in the Library section & it spends hours ‘updating’ to no avail.

When I go back into the failed mount, it states mount.nfs: access denied by server while mounting

Can someone help me out here? This is proving to be rather frustrating and is making a return to RuneAudio fairly imminent.

I am not hugely savvy with coding/terminal etc so please go easy on me.

Thanks in advance for any assistance.

Have same setup

What address did you use in Volumio for Remote directory ?

Mine is below
Untitled-1111111.png

Hello, thanks for getting back to me.

I’ve been trying an NFS mount (using a Mac) & the directory pathway is Public/Music.

I’ll copy yours now and see if that fixes things.

Unfortunately it still isn’t working, I get the following error when copying your settings:

mount error(2): No such file or directory Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

If I change to NFS I get the following error:

mount.nfs: an incorrect mount option was specified

Frustrating

Not sure i can help as never used a Mac

My setup is WD My Book Live plugged into Linksys by Cisco WAG320N Router just wondered what your settings are within the MyBook

Mine
Untitled-2222222.jpg

Yeah, my settings mirror yours so I can’t understand why this is so difficult to get up and running.

How are you connecting the Pi to the Router WiFi or Ethernet as had problems first time when i tried using WiFi so swapped to Ethernet set everything up then swapped back to WiFi

Ps sorry to ask this but are you sure you have the right ip address for the My Book

The Pi is wired to the router.

IP address is the address under LAN Configuration for the MyBook so should be correct.

Looks like I may have solved this issue.

It appears to be an issue with the Apple Mavericks OSX causing issues with SMB.

Thanks for all your help.

Just wondered if you went into the equivalent of Windows Explorer on a Mac what the address looks like for the My Book shared folder

Mine is \MYBOOKLIVE\Public\Shared Music

Got to ask a stupid question why does that matter as the Pi and the My Book run independently from your PC or Mac there only there to control as you can setup from any device with a browser

If you want to mount a SMB share in OSX:

in Finder, you select the menu Go > Connect to Server
or with the keyboard shortcut

CMD K

enter the address as follows:

smb://hostname/sharename

If you change from SAMBA/CIFS to NFS, the old default mount options under ‘advanced options’ are still for SAMBA/CIFS. If you save the settings of the mount and reopen, the correct mount options under ‘advanced options’ should have appeared.

Hi Everybody,

for those of you who still have problems I´d like to tell how i solved the proplem. It works with MYBOOK Live & MYBOOK Cloud ( I own both of them)
First I have to say, that i currently use the RuneAudio Player, cause of the "Connecting screen- problem, but as I read, they are nearly the same…

It was not possible for me to enter my WD shares via the path public/shared Music or whatever. So i decided to create a new user via the web UI of the MYBOOK (-CLOUD). I gave it an own folder and stored my music in it.

With this it all works fine now. There is no more red cross next to the mount.

Here are my settings.
WD_Setting.jpg

Hi there,
Thanks for the suggestion chillkröete. :bulb: After trying every option I could think of I created a new user and share for that user. Put some music in and connected first time! Thanks again. I’d love to know why the “default” owner account and public share don’t work - its a bit of a hassle setting up a second share just for Volumio to connect.
Matt