[Solved] Hifiberry Digi only worked one time, never since

FIXED: See 2nd post.

I got a Hifiberry Digi and want to use it with Volumio. First it worked for a few hours with Volumio 1.4 until I shut off the Pi. When I booted it up again it didn’t recognize the Hifiberry Digi I2S soundcard. Since the driver was still active I thought that my soldering may be broken and checked all the pins with a continuity tester but they are ok. I deactivated and reactivated the driver and even flashed a fresh image of Volumio 1.4 but to no avail.
I’m a bit lost here if this is a software problem or if my Digi card is already dead. The green LED on the Digi board is lighting up though.

Some outputs that may be of interest:

[code]volumio@volumio:~$ cat /etc/modules

volumio@volumio:~$ aplay -l
aplay: device_list:268: no soundcards found…

volumio@volumio:~$ aplay -L
Discard all samples (playback) or generate zero samples (capture)[/code]

Things I tried:

  • fresh Volumio 1.4 image and older Volumio 1.2 beta image
  • checked soldering with continuity tester
  • 1.2A PSU and 2.0A PSU
  • Kernel update with rpi-update

Tried Raspbian, problem still exists.

This is the output of the check-system script provided by Hifiberry.

[code]pi@raspberrypi ~ $ ./check-system.dac
Checking system

Linux raspberrypi 3.12.23+ #692 PREEMPT Thu Jun 26 20:15:50 BST 2014 armv6l GNU/Linux
Kernel: 3.12.23+
PRETTY_NAME=“Raspbian GNU/Linux 7 (wheezy)”
NAME=“Raspbian GNU/Linux”
VERSION=“7 (wheezy)”

Checking drivers

snd_soc_bcm2708_i2s enbaled in /etc/modules
snd_soc_bcm2708_i2s loaded
bcm2708_dmaengine enbaled in /etc/modules
bcm2708_dmaengine loaded
snd_soc_wm8804 enbaled in /etc/modules
snd_soc_wm8804 loaded
snd_soc_hifiberry_digi enbaled in /etc/modules
snd_soc_hifiberry_digi loaded
Sound cards
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
–2014-06-28 16:50:24-- http://www.hifiberry.com/files/sin1000_48khz.wav
Resolving http://www.hifiberry.com (http://www.hifiberry.com)…
Connecting to http://www.hifiberry.com (http://www.hifiberry.com)||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 5760044 (5.5M) [audio/x-wav]
Saving to: `sin1000_48khz.wav’

100%[======================================>] 5,760,044 1.63M/s in 3.5s

2014-06-28 16:50:28 (1.59 MB/s) - `sin1000_48khz.wav’ saved [5760044/5760044]

Playing WAVE ‘sin1000_48khz.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo[/code]

I noticed that snd_soc_wm8804 hasn’t been added to /etc/modules by Volumio and added it myself. It’s working again! I still don’t understand why it doesn’t work under Raspbian but since I only want to use it with Volumio I don’t really care.