[Solved] Doesn't install on Rasp Pi+

I’m very new to this, so forgive me if I’m being stupid! Only had the Rasp Pi+ for a few days, but got it working on Raspian, OpenElec and RaspBMC. OpenElec is the best one for me, I only want to play music. I have downloaded the Volumio 1.41Pi.zip file, unzipped it and used Win32DiskImager to write the .iso file to my microSD card. It all worked okay I think. Plugged the microSD card into Rasp Pi+ and it installed right down to where I see VOLUMIO written in backslashes and hyphens, then it stops with an error and does not continue. I have tried it three times and same result. Here is a photo of my screen:


Any help or advise would be greatly appreciated!


Try to type volumio.local on your pc browser or ip address of rpi in browser

Thanks, I’ll try it, maybe over the weekend if I get time. I’ll let you know how I get on…

Great! It works! However I still have a few problems…

  1. It won’t connect over WiFi, only on Ethernet. I have tried to enter my SSID, security and password, but it doesn’t work (GUI is unresponsive).

  2. I don’t hear anything! Is it compulsory to have a DAC installed? Does it not play through the headphone socket (on Rasp Pi B+) at all, even for testing?

Many thanks!

I am new to this, others know more, but this might help:

1)If connect over wi-fi means that you are typing “volumio.local” into a browser running on a device that is attached to your lan by wi-fi, you might want to try the ip address of the raspberrypi instead. If I am using my Nexus/Chrome browser, I have to use my pi’s ip address instead of volumio.local, which works on my desktop that is connected via ethernet cable.

2)You do not need a DAC. I am using a regular set of powered computer speakers attached to the audio out of my pi.

Hope this helps, or at least narrows the solution search.


Thanks for your post Tom.

Typing “volumio.local” into a browser on a PC attached to the same network did not work for me - indeed I did have to enter the IP address of the Pi B+, and that worked perfectly. I get the Volumio pages in the browser and it all seems to work, except that I can’t get the Pi B+ to connect via WiFi and I don’t get any sound out.

I have one of those tiny WiFi USB dongles plugged in to the board. I can go to the Network setup page and enter my SSID, I can select the security type and enter my password, but it doesn’t connect. It works over a wired Ethernet connection, but not WiFi. Other applications I have tried work perfectly over the same WiFi, but this one doesn’t.

I get no sound out. I have tried both earphones and similar to you, a powered PC speaker set, but there is no sound out at all. In one of the other applications I have tried and that works - OpenElec I think it was - I had to specify the sound output port as to whether it went to the 3.5mm jack or to HDMI, but there doesn’t seem to be a setting for that here. I wonder if that is my problem - the sound is being sent to the wrong output port?

Any ideas?

Many thanks,



Hi, after you enter the wifi settings, save it and shutdown your rpi, remove the lan cable and let the rpi to boot from wifi stick, its booting a bit slower, allow it at least 2 minutes and then type the ip address of your wifi stick. As for audio output you have to choose in playback tab the output device.

Hi All! Thanks for your help…

I have got sound via the headphone socket now! I typed the following into volumio:

amixer cset numid=3 1

I found this on a post in the Raspberry forum and it worked! Amazing!

Now I will try your suggestion about the WiFi dongle and see if I can get that sorted out, then I will have to tackle the problem of the horrible noise in the audio at volumes less than 100%…

Hi All,

I’m going to close this thread now as I have solved many of the problems that I had. Volumio does run on Raspberry Pi B+, even though the last line of code going up the screen on startup says Fail. I have managed to get sound out of the headphone socket too, by telling the Pi to specifically use that output. I think it would be useful to put a switch in Volumio so that one can select the output route.

Thanks for all your help, everyone!