[Solved] DBpoweramp UPnp

I apologise for the basic question but I have just spent a day or so getting the dbpoweramp upnp server to run on a spare raspberry pi (initally had issues with the hard disk having NTFS file format). anyway from the dbpoweramp web interface I can see that it has located my music. My problem is that I cannot seem to get it to talk with Volumio.

Can someone please walk me through the basic configuration of Volumio to recognise the upnp server:

Looking on a windows computer the upnp server appears as : Asset UPnP: raspberrypi
The ip address is:
The CIFS (SMB / Windows) Network Share is apparently: /home/pi/nas
The music files on the HDD are at: /media/usbflash/

Do I need more information, whatever I try so far fails.

I appreciate any help.


I tried just using the correct IP address and NOT specifying a remote directory and I get the message “mount: Connection refused”

Looking at my home network I can see the Asset UPnP server and it has the correct IP address. Also if I click on the albums folder I can select albums and successfully play them through the computer. So the server works I just need to configure it to Volumio.

Any ideas?


Problem sorted. It was my own stupidity! I downloaded a UPnP controller App onto my I phone and Volumio works fine.

The first App I used was Linn’s Kinsky, which I found unintuitive and also only plays the first track of an album then stops. Looking round the internet others have found this issue. Something to do with not recognising that the player has finished the first track and thus doesn’t start the second?

I also tried 8player lite, which on a quick look does appear to work.

What is the best UPnP controller App for an I phone?


BubbleUPnP works good for me (on Android)
I think they also have a IOS app.