[Solved] Can't mount share from Zyxel NSA325v2

Hi there,

up to now, I’ve been running Volumio (on Raspberry Pi) quite successfully with a library served through my server running Openmediavault. I now replaced the server by a NAs (Zyxel NSA325v2). Copied my music there, it is to be found in a share called “music”. So far, I have not been able to mount it in volumio, however hard I try.
I followed the guide smb-cifs-shares-volumio-t1461.html. According to that, the share should just be set to the IP of the NAS and the name of the share (according to Win Explorer, it is just “music”, resulting in //xx.xx.xx.xx/music . Doesn’t work. The share is public, but even if I give username and password of admin, it doesn’t help.
I also tried to include the full path as seen in the NAS configuration panel, which would be something like name-of-volume/music - no result.
Also tinkered a bit with advanced options / mount flags as indicated in the forum post mentioned above, didn’t help either.
I’ve been using Volumio’s WebGui.
I’m kind of stuck here… The public share itself can be used from all other devices except volumio: Win PC, Android Smartphone, Android tablet, DAB radio with dlna / upnp.
Any hint? Does anyone run Volumio with the Zyxel NAS and can help?
Thanks, Uwe

It may be simialr to what I am seeing - albeit I m not using Zyxel NAS, im using a debian based machine else where with samba and sahred folders.

Can you ssh into volumio and then at shell prompt run " mount" ?

This will provide you with the list of mounts as seen from distro.

In my case the mount is there - I can browse mount using shell - its just that the webgui doesn’t see the mount - In my case looks like a permission issue.
Im still investigating further.


Hi Woody,
thanks for your reply! No, I can’t see the mount via SSH :frowning:
Need to look further, obviously…
Thanks anyway, Uwe

Got it! I was so desparate that I prepared a fresh Volumio install, et voila - worked smoothly, no hassle at all. Strange.