[SOLVED] Can't mount CIFS network drive after 2.599 update

Just updated from volumio v2.452 (aug 2018) to v2.599, and now I can’t ‘Find Network Drives’ or mount a SMB share over the network in volumio setup wizard. This all worked just fine in v2.452.

Network drive is a SMB share on a Win7-64 Pro sp3 host. From volumio v2.599 I get:

Error in adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t cifs -o username=‘pete’,password=#######,ro,dir_mode=0777,file_mode=0666,iocharset=utf8,noauto,soft,‘vers=1.0’ ‘//’ ‘/mnt/NAS/pete_music’ Unable to find suitable address.

Setting vers=1.0 or vers = 2.0 in Network setup : Advanced doesn’t work either.

Log files here: http://logs.volumio.org/volumio/EsYG2B1.html

Any help appreciated, thanks.

You are getting a mount error 111, which means “connection refused”. I have no idea why this would happen suddenly, did something change re. permissions? Or do you need to supply uid/passwd?

Thanks for the reply. The only thing that changed in my setup is the update to v2.599. No change on LAN or router, no change on NAS (SMB/CIFS via Win7-64 Pro sp3) , no change in permissions anywhere (that I initiated). Yes I supplied uid/pwd via volumio network setup wizard - you’ll see those creds (fuzzed) in the error message from my first post.

I’ll check permissions at the SMB share - wouldn’t be the first time Win7 changed the sh!t without warning.

Yeah, there’s been no change at the Win7-64 Pro SMB share - permissions are identical to when volumio v2.452 could access it. I actually have another RPi 3B+ running v2.452 and it continues to access the share just fine.

So I’m stuck - es klappt nicht mit v2.599.

Solved - I was using the wrong IP for the NAS host. How embarrassing : |

Before that I had reflashed to a new SD card, using the berryboot image for volumio v2.599 (not the create-your-own-image process following the ‘official’ Volumio instructions). So my new config is booting volumio via berryboot, but this wasn’t a factor in my CIFS mount issue: that was simple idiot user mistake.

This time v2.599 found the SMB host under ‘Find network drives’ in the Network Setup wizard, but It still did not find any of the SMB shares connected to the host

So I manually entered the [correct] IP to the SMB host, added the share name, user name and password, and v2.599 connected just fine.

I did NOT have to use vers=1.0 / 2.0 / whatever.

In case any of this helps anyone else.