[Solved] Can't make USB Wifi to work - TP-Link WN727N Ver 4

Hi everyone,

Bought the tp-link wn727n after reading about it’s compatibility with raspberry pi, only to realized that mine is ver 4 instead of ver 3 that is listed as compatible. :frowning:

Tried looking at raspberry forum and they already directed me to the right driver, but after tried it still no luck.

Is there anyone can help me with this?

And upon looking on the list of compatible wifi dongle list by michaelangelo, edimax dongle is listed as compatible, does it work right out of the box?


P/s: I’ve not sleep for few days already trying to figure this out… :frowning:
I’m totally new with all this Linux thing…

Please, could you give us what return the command “lsusb” in ssh terminal ?
Type lsmod to see if you have drivers installed and loaded .
If drivers are loaded type “sudo iwconfig”.
You sould see three device :
wlan0 : wifi (if so it’s good!)
lo : loopaback
eth0 : ethernet.
So if it’s ok, go to the webUI / network and wireless connection set your SSID and your password if needed. Save change. You should see (I guess) a blinking light.
Let’s us know

Hi balbuze,

Thanks for the reply, I’ll post the pic of the command that you asked after this.

hi balbuze,

this is what i get when using your command:



sudo iwconfig

from lsmod i think the driver is loaded because i saw the “mt7601Usta” but that is only my guess.

also from sudo iwconfig, i think the ra0 is the wireless because it’s using ralink chip, and i’ve read at raspberry forum also regarding the ra0.

when looking at volumio network area, connection status for “Wired Connection” is “Connected” but for “Wireless Connection” the status is “No Wireless Interface Present”. :frowning:

i’m thinking of buying the edimax with hope that it would work, but i believe i’m already getting somewhere with this tp-link so any help is greatly appreciated.


Hi !
Could please give what “sudo ifconfig” return ?
The driver seems to be loaded but have you copied the firmware in the directory ?
Create directory /etc/Wireless/RT2870STA
Copy RT2870STA.dat to /etc/Wireless/RT2870STA directory
You find it in the tar.bz2 file from the site : mediatek.com/en/downloads/rt … 870rt2770/
Maybe have you alaready had a look at gowthamgowtham.blogspot.fr/2013/ … er-in.html ?

hi balbuze,

sudo ifconfig is giving this:

sorry if it sound stupid but how do i create a directory and copying that .dat files into it?

First of all, just some basic linux command:
ls : list the content of the directory
cd : change the directory (ex cd /home/volumio)
cd… : go to the previous directory level
mkdir : create a directory ( mkdir /home/volumio/toto )
pwd : show the current directory
rm : remove a file ( rm toto) !!! if you use it, espacially with sudo, you can easilly break your system !!!
In volumio there is a file manager (midnight commander) you can use by typing mc
sudo : you have to type it before each commande that require root right.
In linux command are case sensitive : ls is not LS or Ls…
Check if your previous installation created the dirctory :
Run a terminal via ssh
type: ls /etc/Wireless/RT2870STA
if no error, the directory exist and content will be displayed.
If the directory does not exist :

sudo mkdir /etc/Wireless/RT2870STA
[/code] to create it.
and from the place you have the file RT2870STA.dat you copy it : [code]
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA

just a link for RT2870STA.dat : dl.dropboxusercontent.com/u/442 … 870STA.dat

Hi balbuze,

Thank you very much for the reply and guides, I’ll try to do it.
Only before I proceed, say I download the .dat file into my PC, how do I copy it to the directory that I create as per your guide?

Also I saw in another forum the wget function, if using it, where will the downloaded file go?

Sorry for the hassle and thanks again balbuze.

yes from your terminal you can type wget https://dl.dropboxusercontent.com/u/44287012/mt7601/3.6.11%2B/RT2870STA.dat it will download file in your current directory :smiley:

hi balbuze,

i’ve done what you told me to do, and also following the direction from the gowthamgowtham blog, and it seems the driver is loaded, and use command sudo iwconfig the ra0 seems to work after reboot, so i put the ssid name and password on the gui, but same thing happen, “no wireless interface present”.

and also after reboot back, it seems using lsmod the driver is not loaded, and all the changes that i’ve done at /etc/network/interfaces is not there, even when i already save it.

All changes you do manually will be erase at each boot time.
In webUI / network clic on reset to default
reboot and try to reset your parameters…
Sutpid question but in Webui do press “save changes” ?

Please ave a look here : ftp://ftp.meta5.com/MT7601Usta.tar.gz
and use the driver for your kernel : Volumio 1.51 use 3.12.26

hi balbuze,

i’ve done as you asked, reset and save in the gui, but still it’s not working.

redo everything back as per gowtham’s blog, and using sudo ifconfig giving me this;

i don’t know what to do anymore. :frowning:

just to ask, do i have to do all this thing if i’m buying the Edimax dongle?

and do i have to re-enter everything back every time i’m reboot as you said it will be erased?
i just ordered the edimax by the way, this tp-link is getting me nowhere, but seriously thanks for the help and guidance.


I’m sorry to see it still don’t work :frowning: but you are close to success… Driver is loaded. The thing I don’t understand is why your setup is not take in consideration. What contains the file /etc/network/interfaces ?
No you don’t t have to redo that each boot :smiley: only once ! But if you change your Volumio version you’ll have to redo…
For the edimax I don’t know if it will work out of the box . there 3 categories of dongle:

  • running out of the box
  • running after manual installation :wink:
  • not supported at all due to the lack of driver from manufacturer…

Hmm, I’ll try to do it again and post the image of the content in /etc/network/interfaces, but I personally think I’m running out of luck with this tp-link, really hope that the edimax will work out of the box.

Balbuze, say if I’m using edimax and it’s not working out of the box, do I have to reinstall the volumio as the wifi dongle is different?

No you don’t. :wink:

hi balbuze,

this is the content in my /etc/network/interfaces

I think the problem is due to the fact that Volumio use wlan0 as WiFi interface and your dongle provided ra0…It’s hypotesys…
So manually change wlan0 to ra0 in your /etc/wireless/interfaces
But it will be erase each boot
Michelangelo could you confirm ?

Yeah, the erased issue is the one I fear, as my previous question to you.
So it seems like I have to changed the wlan0 to ra0 every single time I boot it.

balbuze, thank you for keep on helping me with this.

Hopefully when my edimax arrives I don’t have to face such issue as this. :slight_smile: