[Solved] Can't Get Wifi On RPi

Hi, this evening I discovered Volumio, and I wanted to try it. I own 3 Raspberry Pi, so this is not my first attempt to flash something on it. I flashed volumio img as usual (dd), connected to the lan, inserted wifi doungle (rpi-compatible, bouth on farnell 14 (called Wi Pi), tested with many linux distro). It wouldn’t boot.
Removed the Usb wifi dungle. Connected to my raspberry ip, got to the web interface. I also logged in to ssh. As soon as I insert the wifi card, lan get disconnected. no way to set up wifi connection. Waiting some minute, however, lan come back, but on the web interface it wont find the wifi card (under connection menu).
Do anybody knows why? This project seems fantastic, everything is really cute… but this.
Thanks, Nicolò

Strange that, I was having the exact same problem this evening.
Works fine with LAN cable, insert WIFI dongle and I loose connection…

Looking forward to hearing any tips toward sorting this…


The Pi reboots when you insert any kind of USB device… So connect the Wi.Fi dongle before turning on the pi…
If it doesn’t boot properly that could be a power issue (use another power supply). If this doesn’t work please paste the output of :


ifconfig -a


We’ll get this sorted! :wink:

I’m using a 2A PSU and a self powered hub so as not to stress the Pi USB ports…

I’m going to start from square one with a new flash and will connect all the USB parts before boot up
as you advise…

As I say, it works perfectly using cabled LAN alone.

Thanks for this great software, just what I was wanting :smiley:


Powered on with WiFi Doungle inserted. Connected to volumio.local, web interface loads, but no wlan card shown. Connectet to ssh.
Commands given with sudo
ifconfig -a:
(wlan0 present)
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

Adding ESSID /encryption on the webui, saving: I get a “connecting” and ssh freeze. I do wait. ssh come back, but on the webui i get "wlan0 IP address: — NO INTERFACE PRESENT — "

edit: Once rebooted, it does not show with an ip scan (lights are all on). Cut off power. Remove USB. Power on. Again invisible.
No way to get it online again. Manually edited file on SD card: commented out auto wlan0 staff. Again offline. Removed Wifi Dongle. Nothing changes.

Fresh install of Volumio
Intaleed USB WIFI dongle. Lan cable and USB DAC.
Booted up and set the wlan SSID and password…

After 60 seconds connecting, it showed No Interface Present in the wlan box

Started again but this time using another USB wifi dongle…

Set up SSID and password…
This time after 60 seconds connecting it showed no IP address in wlan section
but this time it was not reporting No Interface Present…
So, it seems my problem is that no ip address was allocated to the wlan…

I have the eth0 DHCP set to enabled (Auto) and the wlan security set to (No security)

Below are my files as you requested…





SOLVED! But I’ll never understand how. Well, the problem seems to be the WEP encription. Changing the WEP from “BBBBBBBBBB” to “BBBB-BBBB-BB”
I’ll wait to change the post title 'till I’ll be sure this work for @geppetto too.

I have the same problem as you.

Did you edit the text file in /etc/network/interfaces to make it work

What was the final format, I have a SSID and a password



Good work, for some reasons we need to change the way security is handled. When you find out more please let me know so I can better understand the issue… Thanks!

edited /etc/network/interfaces
Here how it looks now:

[code]auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp

wireless-essid NETWORKNAME
wireless-mode managed
wireless-key BBBB-BBBB-BB

auto eth0
iface eth0 inet dhcp[/code]

Thankyou the above interfaces file worked for me, have updated my original post

I’m also having fun trying to get wireless setup on Volumio. My interfaces file looks different as im connecting using a WPA2 SSID. I bought a cheap Ebay RPI compatible USB dongle that works with all other RPI images I have tried so far? Any suggestions?

Would love to get my Frankenstein IPhone dock kitchen streamer working before the weekend is out :smiley:

I’ve had the same issue - only started installing today…having followed all of the advise above, it still did not work.

What did finally work was setting the network name - it is case sensitive on Volumio - and I have it in quotes:

auto lo
iface lo inet loopback

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp

wpa-ssid “NetworkName”
wpa-psk “password”

#auto eth0
#iface eth0 inet dhcp

This problem is still relevant, at least for me.

Despite following the Volumio installation wizard which includes setting up WiFi, it doesn’t work on subsequent restarts. I still have to edit the interfaces file to get WiFi reliable. I put in the SSID of my WiFi and password in plain text, and that seems to do the trick.

I use a RPi2 with Edimax WiFi USB dongle.