[SOLVED] Android App configuration/error

Hi all, first post.

I’ve searched a lot for this already but every search I do is refused due to usage of common words, so I’m forced to post.

I have everything up and running from web interface no problem (via opt on digi+ (something I had a big problem with on Rune even though I’d changed config.txt etc)). Trouble is Rune app worked beautifully but I can’t get Volumio android app to connect.

Galaxy S6, Volumio connected via LAN (also via wifi connection too).

I’ve tried

  • Actual IP address (confirmed in Avahi Zeroconf Browser),
  • both with port number specified and without etc.

Without port number specified - I click save then next and the blank page is a slate grey colour, that’s it.
With port number specified (in this case port 9) - Web Page Not available (net::ERR_UNSAFE_PORT)

Any help appreciated (I went with Rune in the first place purely due to poor App store reviews for Volumio, I hope this isn’t as broken as it seems as control of the device is vital via smartphone really).


Which android app are you using, or do you mean using a browser?

The IP address corresponds to the Volumio hotspot, which means you will need to connect your phone to that wifi network.

Sorry, but it is not clear exactly what is not working :frowning:

Ah right, just go to any browser on the phone and put the IP address in and it works.

What I was doing (the original problem (above)) to replicate it:

  1. Go to Google Play store on your smart phone
  2. Download and install the Volumio app
  3. Try to use it.

In the app small print in the app store it should just say “put the IP address of the device in your stock browser” and that’s it.

Another less polite way of saying this is perhaps there doesn’t need to be an app in the app store at all, as it doesn’t work well, as confirmed by the ratings here:

play.google.com/store/apps/deta … e&hl=en_GB

Although, granted, I’d prefer a dedicated app like Rune has, and one that works that well, using my phone browser option is a sufficient workaround.

Thanks again for responding, hope that explains it better.

I think that the existing Volumio app in the Google app store is only good for Volumio 1.x and not the 2.x version. The developer isn’t (AFAIK) part of the Volumio ‘team’ and did it because he could. As you found, the answer is simply to use the web UI offered at the player IP address, then it works very well…

Glad you got it running,

Chris M