[Solved] Airplay name won't change from volumio

Hi, I am trying to create a multi room system using 4 raspberry pi’s running volumio. I can’t get the airplay name of each one to change from volumio.

Have tried sudo nano /etc/init.d/shairport and changed name here.

also sudo nano /etc/hostname and sudo nano etc/hosts and changed names in here.

Anyone know what to do ?

Unfortunatly Volumio no longer seems to use the init.d script but starts shairport in the /var/www/command/player_wrk.php script:
I changed the name to VolumioAir and changed the device “hw” construction (to -d default:M2496) in order to get my Musical Fidility V90 usb dac to work without generating a lot of noise:

// Start Shairport with Volumio name, stopping Mpd on start, with Selected output device $cmd = '/usr/local/bin/shairport -a "VolumioAir" -w -B "mpc stop" -o alsa -- -d default:M2496 > /dev/null 2>&1 &';

Changing the code and rebooting worked for me (toggling the airplay option in the webinterface didn’t)

Thanks, that worked a treat with airplay. However when i use Linn Kinsky or another upnp client it still says Volumio as the name. Any idea which script it is using for that ?

In case of upnp volumio seems to use the init.d script /etc/init.d/upmpdcli, this reads the configuration file /etc/upmpdcli.conf
In this conf file you can define the UPNP "friendly"name:

# Displayed "Friendly Name" for the UPnP Media Renderer friendlyname = VolumioUpnp


Losing the ability to change the Airplay name is a real drawback. I’m running 3 x Volumio with IQaudio DAC in my house and now cannot upgrade past V1.3 because of this. The fix described above doesn’t work for me.

Can the feature be re-introduced please? V1.4 is a real improvement, particularly stability and the Library view on the web GUI is excellent.

Hi agree that name change is an essential feature in the UI.

Well done Marcos for finding the workarounds = very helpful for me. Many Thanks :smiley:


by changing names as above it works for me. at least my router display new name correctly. :mrgreen:

Hi Marcos
Brilliant ! Thanks !
Just a small note: if you are not sure what is the actual name of your DAC, type <aplay -L> to find out.