[Solved] 1.4 on RPI - soundcard select and airplay issues

Just installed 1.4 and noticed the problem I reported here is still present. I had to manually edit /etc/mpd.conf to get the sound to my USB dac. When getting that to work I tested airplay and I can not get any sound from it. I can find Volumio in my iPad and send the sound to it, mpd then stops playing but I do not get any sound. Can that be connected to the fact that I can not select my dac as output device from the drop-down meny in the web ui?

Airport will not work if you just select your output device changing mpd.conf. If you cannot select your DAC, that’s probably a browser cache issue. Reboot, go to output selection and hit ctrl + f5 on your browser. Then select your USB DAC. To make sure everything works, just check mpd.conf has been updated correclty. Let me know.

I had to select “L20” and reboot, then it worked. I suppose L20 is my DAC then? I have never seen it being called that before.

Still have problems with airplay. The sound is very distorted, I can barely hear what song it is. Playing songs from my NAS works fine. Rebooting did not help.

No one else having the same problem with airplay?

I have problems with airplay. It works with PI internal soundcard. But it does not work with my DragonFly DAC.
This is my shairport start-command: /usr/local/bin/shairport -d -a “Volumio” -w -B “mpc stop” -o “alsa” – -d “hw:0,0”
hw:0,0 is correct. Works in mpd.conf
Using shairport this way starts playing, but only white noise from the left channel is comming out of my DAC.

I can report the same issue with Shairport - MPD is configured correctly and plays just fine.

Shairport is using the same hardware output, and starting a session with it stops the MPD playback as expected - except, all I get is noise from the outputs. Stop the shairport session on my other device, and go back to MPD playback and all is perfect.

Michelangelo - given the shairport integration with the Web GUI, where can we modify the shairport initialization to include logging? Shairport will write a pretty noisy log, but it might be helpful to enable it temporarily to troubleshoot the playback issues people are having…

I also can report a problem with airplay. Sending Spotify from an android tablet (via AirStream app).
Audio is very distorted.
Music play from Samba share works perfect, it’s just Airplay.


I have this issue as well with my DragonFly DAC.

Files play from the RAMPLAY directory OK (some crackles and pops)

Airplay doesn’t work. I get static and in the background a high pitched version of the audio file.

This sounds like a sample rate issue, but I have tried via the GUI selecting all possible audio output formats with the same outcome.

Also, when I save the sample rate converter always switches back to “Fastest Sinc Interpolator”.

Actually, I just got it to work by editing this file:


and changing the shairport command to this:

$cmd = '/usr/local/bin/shairport -a "Volumio" -w -B "mpc stop" -o alsa -- -d default:'.$device.' > /dev/null 2>&1 &';

Is the “-d hw” option and parameter combo deprecated in shairport?

I still get pops and crackles occasionally, even on webradio and local files…

Hi kais,

thank you very much for your post. This solved the airplay problem for me, too.

This does not work for me, immediately upon sending audio to the airplay device “Volumio” the service crashes.

Looking at the shairport documentation, and the command line options you can see when you do a “ps ax | grep shairport” - you will see that the way it’s set up before the mod suggested in this thread appears to be correct. (i.e. what you see is the -d option match the selected output for MPD in the volumio UI. In my case, that’s “hw:2,0” which is a correct designation.

What the mod suggested here is doing is to set the output to the system’s ALSA default, which may or may not be correct based on what system you’re running. On a Cubox-i, for example, the default is NOT a USB DAC, it’s the on-board SPDIF output…

Hi kais

Thanks a lot for your trick that solved my Airplay distorted sound issue with Volumio 1.4

Did you try : http://volumio.org/forum/audio-dropouts-t1478.html#p5764

Let me know if this helps.