Software Volume Doesn't work with Hifiberry Digi+ Clone

I’ve just assembled a music player to replace my Squeezebox duet, comprising of a Raspberry Pi Model 2 B+, with a Pifi digi+ v1.0 HAT (Hifiberry Digi+ clone).

I initially tried Runeaudio, which was ok (and software volume working ok). I then went on to Volumio 2, which seems to me to be an all round better proposition, with a far more attractive GUI. The problem is, I can’t get the Software Volume controller to work, which is a show-stopper for me (since the Amp is a bit awkward to get to).

I’ve trawled a lot of forum posts, articles etc and tried various approaches, modifying mpd.conf & asound.conf, all to no avail. The volume remains the same whether the software volume dial is ‘unlocked’, or not.

Software Volume control seems to be problematic, from my research. Does it not work for the Hifiberry Digi+, or is there a magic incantation, I can use?

  • Raspberry Pi Model 2 B+
  • Pifi Digi+ HAT (clone of Hifiberry Digi+)
  • Volumio V2.175

Why would you want to use the software mixer? In principle the worst solution.
Controlls the HifiBerry clone not the hardware mixer? This changes the volume virtually loss-free.

A software mixer reduces the sound quality. Therefore the hardware mixer is allways the better choice.

There is currently a bug in the software volume control introduced by latest release, we’re working to solve it

Hi Jens, thanks for the reply. Yes, I understand the drawbacks of using a software volume control, but the DIGI card has no hardware volume control, and my amp is inconvenient to access, so software volume would be the more pragmatic solution. If I get the software volume control working, I’ll do some comparisons and if the software volume control is too bad, then I may have to consider removing a door from a cupboard to enable line of sight to a remote control :wink:

Ah, ok, thank you for the reply. I’ll wait to see. Weirdly enough, I came to the Volumio site for the first time, on the very day you GA’d the latest release.

I have succeeded in getting a mixer configured and working via ‘alsamixer’ or ‘amixer cset’ but failed to cross the finishing line with regards to making it work in the gui.

I am also having a problem with software volume and Mamboberry ls DAC.
when switch to software volume everything freezes and I have to restart. the UI then goes back to no volume control.