Software mixer: Volumio 2.0

Hello guys,

at the beginning, please let me congratulate on the first stable version of Volumio 2. It is really beautiful piece of work :slight_smile: I have downloaded it and tried and must say it looks fantastic. However, one small problem it seems appeared - software mixer. In the playback options I can only select Hardware mixer while on Volumio 1.55 I had an option to have Software Mixer as well, which actually was working while I did not have any results with the Hardwer Mixer. Can you please help how to enable Software Mixer in Volumio 2.0 stable?

Thank you,

Hi, what audio device do you have?

I am running Volumio 2.0 stable on RP1 B+ and having DAC HRT Music Streamer II

If it tells hardware mixer is because your DAC is capable of that. Do you see any options in the mixers? Can’t you set the volume?

Unfortunately no, when I try to increase or decrease the volume nothing happens, it keeps constant level. Also, the volume changes do not go slight, but when I click on certain part of volume circle the change in level number has small delay, but still without effect on the volume level. Regarding to mixer options, I do not have any neither on DAC nor in Volumio, only possibility to set up the starting volume, start-up sound, etc. without possibility to influence the hardware itself.

I have exactly the same issue on my RPi 1 with Sound Blaster X-Fi DAC.

The same thing with R2 model B. How to turn on sw mixer?

Problem still persists on newest build (v. 2.003). I can’t select software mixer on my Pi 1 B even when I choose another audio output (mini jack or hdmi). Is there any way that I could help you with resolving this issue?

jack and hdmi output integrate hardware mixer, it’s because it don’t need software mixer.

Ok. What about DAC connected to Pi then? I remember that software mixer worked with my DAC on Volumio 1.55 but on 2.0 it does not. Only option available for me (and few others as I can see above) is hardware mixer which does not give any volume control :frowning: Can we help it somehow?

Yes, the mixer thing is still buggy… I’m fighting since months with it…
I think I will make all selection available then …

I would say I’ve got a similar problem with a usb amp/dac showing a hardware mixer with no effect…
In volumio 1.55, the software mixer was managed by mpd. (correct me if I’m wrong). In volumio2 it is a alsa software mixer. It allows software volume control for any app runnning in volumio (mpd, spotify, airplay etc) and not only mpd as in volumio 1.5

@michelangelo : I was writing when you answered… Just to say that before you wrote the softvol I made tons of test to make a softvol for the loopback device for brutefir…with no success… no sound changing

Ok guys, thank you very much for info and of course for your work on Volumio. Let me know if I can help you somehow (by providing logs or more detailed info), apart from my noobiness in coding… :wink:
Thank you and good luck on working that issues out in no time!

I am experiencing the same issue. I have a Cambridge Audio DAC100 attached to a Raspberry Pi B. Although it should support hardware volume control it has never worked. I’ve always used software volume control in previous releases.

Software mixer type is not available on release 2.001.

Running the latest 2.x release for x86 with Topping D20. The software mixer option is not available; the hardware mixer option won’t control the volume as previously reported.
I am away from my Volumio player right now, but could provide logs at later time, if that would help.

Thank you guys for you hard work!


All fixed and working with v2.029


Very good!