Snapcast + Spotify issue

Hello!

I’m trying to configure Volumio + Snapcast + Spotify using this guide and i’ve got some issue…

Everthings works fine when i’m playing local file or web radio to all my rooms but it dosen’t seems to works with spotify… allready search on internet but didn’t found anythings to help me with that.

Somebody does have a tips for it ?

Thanks by advance :slight_smile:

Well, basically newer versions of Vollibrespot uses a toml configuration file, instead of passing flags to the binary.

So, as suggested in


You could try:
sed -i -- 's|device =.*|device = \x27/tmp/snapfifo\x27|g' /data/plugins/music_service/volspotconnect2/volspotify.tmpl
sed -i -- 's|backend =.*|backend = \x27pipe\x27|g' /data/plugins/music_service/volspotconnect2/volspotify.tmpl

Thanks for your reply @ashthespy :slight_smile:

If i understand well, i need to connect with SSH to my rasspberry and run those commands with sudo in the begining ?

So i did, after i desacticate/reactivate de plugin, restart Volumio and still the same :pensive:

Can i share some log or something ?

Yes, these commands are via ssh/terminal, and you shouldn’t need sudo
So try something along these lines

systemctl stop volspotconnect2.service # Stop VLS Daemon
sed -i -- 's|device =.*|device = \x27/tmp/snapfifo\x27|g' /data/plugins/music_service/volspotconnect2/volspotify.tmpl
sed -i -- 's|backend =.*|backend = \x27pipe\x27|g' /data/plugins/music_service/volspotconnect2/volspotify.tmpl
systemctl start volspotconnect2.service # Start VLS Daemon
# Check the logs to ensure everything is working fine..
journalctl -f -o cat -u volspotconnect2.service

So i tryed the commands and it still not working, here is the log

It’s seems to have some network issue but i don’t know how to fix it :relaxed:

[Vollibrespot] : dropping truncated packet from V4(192.168.1.1:5353)
[Vollibrespot] : dropping truncated packet from V4(192.168.1.1:5353)
Stopping Volspotconnect2 Daemon...
Stopped Volspotconnect2 Daemon.
Starting Volspotconnect2 Daemon...
Started Volspotconnect2 Daemon.
vollibrespot v0.2.2 cd96399 2020-10-07 (librespot 08d8bcc 2020-10-07) -- Built On 2020-10-07
Reading Config from "volspotify.toml"
[Vollibrespot] : Using Pipe backend with device: /tmp/snapfifo
[Vollibrespot] : Failed to register IPv6 receiver: Os { code: 19, kind: Other, message: "No such device" }

Just in case, here are some screenshots of my plugin config.

Server (Volumiosalon):

Client (Volumio_sdb):

Reply to myself :slight_smile:

It’s seems to works with the MPD and server config from here

The only things i have to figure it out now is: Normaly it’s existing a specific stream in the spotify app i think, like VOLUMIO-MPD or SNAPCAST to stream everywhere ?

Because for now, i have to select the “main” volumio to play the music everywhere…

I can’t comment on the rest as I never tired snapcast, but from your logs, VLS is setup correctly and writing data to /tmp/snapfifo.
The warning below about IPv6 is just a warning as Volumio disables IPv6…

VLS is setup correctly and writing data to /tmp/snapfifo

Great news :slight_smile:

The warning below about IPv6 is just a warning as Volumio disables IPv6…

Ok, no problem with this.

Thanks for your help @ashthespy! I’ll wait if someone has got other tips for the Snapcast stream.

I’ve been working on this, have to check on my pc later if I patched this already on GitHub (on my phone now). A fix is available :wink: the plugin needs some patching for the toml file, nothing too fancy.

Thanks @Saiyato, I’ll wait for this :grin:. And thank you for all your work!

@pasoad did you ever find a concrete solution to get spotify connect to work?

Still the same… it’s working when I select my principal volumio client (here volumiosalon) but I don’t have a specific Spotify connect for all my device