Snapcast not working on a fresh Volumio build

Hi Ad,

I’ve put some time in addressing some of the issues, please do keep in mind we’re doing this in our spare time :wink:
There’s still some testing to do before I’m comfortable committing to the store.


Thanks you for your answer.

Yes, I know. [emoji4]


Verstuurd vanaf mijn SM-G960F met Tapatalk


One question.

At the moment I am using 4 raspi 3B, 3B+, 4’s with all different configurations.

Could it be possible to add an option to add some delay to get all 4 raspi’s synchronized?

Or is there an other option to synchronize them?

Thanks for the good work!

Many regards,


Verstuurd vanaf mijn SM-G960F met Tapatalk


This are my notes to get the snapserver working.

It is not be optimised at all, but since it is the 3rd time i search for 2h how to get it working this time I took some notes.

Take care and stay home !


Using image
Install volumio and do the wizard to get the basics working.

Install the snapcast plugin from the web interface -> Errors when you turn on the plugin.
Uninstall the plugin from the web interface.

x.x.x.x/dev/ (enable ssh access)
ssh volumio@
sudo su -

apt update
apt install unzip
cd /data/plugins/
wget …
cd volumio-snapcast-plugin-master/
cd /data/plugins/
mkdir -p miscellanea/snapcast/
mv -T volumio-snapcast-plugin-master/ miscellanea/snapcast/
cd miscellanea
chown volumio:volumio snapcast -R
cd snapcast
chmod +x

Web interface snapcast settings-> Enable the plugin

rm /etc/asound.conf
touch /etc/asound.conf
chown volumio:volumio /etc/asound.conf

Web interface snapcast settings -> snapclient : check soundcard to use -> Save
Web interface snapcast settings-> Patch ALSA configuration -> Patch File

x.x.x.x/dev/ (disable ssh access)

Hi Ad,

The whole purpose of SnapCast is syncing them, you shouldn’t have to manually add delays.
As for the possibility, I’m pretty sure it’s not possible. However the snapcast project is open-source, you can find the code here: it’s written in C++ (not really my forté). :wink:

You can adjust the delays using the android client for example.
It is part of each snapclient settings.

Good find, was looking in the wrong direction, so yes you can add delays :unamused:

Hey guys,

I was having this exact problem, and tried TomR work around, which gets snapcast functioning. Might be worth publishing this as an official guide, until Saiyato can fix the broken plugin due to the newer version of snapcast needed specific dependencies that are not available

Hi all.

I’ve tried the work around but the snapcast server is not enabled on reboot, there are no settings and no audio is heard anywhere.

I’ve come to volumio from trying mopidy and have noticed that the same issues of ‘breaking’ the audio output happen with mopidy with the latest versions of snapcast and shairport.

Simply, the only way I could get shairport-sync to work with snapcast was by using the pipe backend and pipe @ tmp/snapfifo- even the instructions on snapserver GitHub for airplay stdout install didn’t work. But this broke all other audio on mopidy. When I comment out the backend, airplay works (but no snapcast) and mopidy and snapcast works for all other streams.

Now I am a complete novice but can is assume this is a similar issue with volumio? Some issue with snapcast, shairport-sync and pipe???

This fails so I guess things have moved :frowning:

I still have this issue, is there a new fix?
The above command returns:
HTTP request sent, awaiting response… 404 Not Found
2021-01-04 17:09:21 ERROR 404: Not Found.

converted ‘http://…’ (ANSI_X3.4-1968) -> ‘http://…’ (UTF-8)
–2021-01-04 17:09:21-- http://…/
Resolving … (…)… failed: Name or service not known.
wget: unable to resolve host address ‘…’

Good evening,
I tried to install Snapcast on Volumio 2.861 here, but both via GUI and CLI the installation fails.

When installing via the GUI, I subsequently get the following error message:

Startup failed
Could not start the SnapCast plugin in a fashionable manner.

Restart failed
Restarting snapserver failed with error: Error: Command failed: /usr/bin/sudo /bin/systemctl restart snapserver Failed to restart snapserver.service: Unit snapserver.service is masked.

When installing via the CLI, the plugin cannot be started and the configuration dialog is empty.

Best regards