Snapcast not working on a fresh Volumio build

I rebuild some raspberry related volumio systems (I used a raspberry2 a raspberry 3b+ and a raspberry zero W)
for a multi-room sound system at home. I used to have a working synced multi-room system based on Volumio
and the embedded Snapcast plugin but now I can not get it to work.

After flashing the newest Volumio image to an sd-card and after installing the snapcast plugin a lot of
error massages are showing up.
The most important one comes up when enabling the plugin:
“Could not start theSnapCast plugin in a fashionable manner.”
Together with:
“Restart failed
Restarting snapserver failed with error: Error: Command failed: /usr/bin/sudo /bin/systemctl restart snapserver Failed to restart snapserver.service: Unit snapserver.service is masked”

In the plugin settings more error messages show up everytime I try to
save anything.

Does somebody have the same issues with SnapCast?
Maybe the problems are due to the new plugin release from october2019.


There’s something wrong with the installation package, already on it, but it takes some time to investigate.
It’s already posted on Github, so I will post the updates there if I have some. :wink:



gladly I found this post here.
I spent hours with new installations. Now I know that’s not my fault…
Hope you can fix it soon.

Thanks for spending so much time for coding

Hi all,

I found the culprit, the latest Snapcast release had dependencies which are unavailable in Debian Jessie. I patched the installation script to use the previous one instead. The PR (371) has some minor conflicts, which will be sorted on short term I trust. After that you can install it from the store again.


I installed today the latest volumio image und added snapcast plugin. But I still got errors!
@saiyato: should the plugin work again? or are the still some minor errors?
I would be great if I can use snapserver again!
thanks for any tips

The latest images write asound.conf for the root user, this will cause problems yes. I’m trying to work around this, but it’s hard without changing the file owner. So yes, you might encounter problems, and yes I’m working on it.

I might need to amend the install script, not sure where this is coming from exactly, so I’m hoping the fix the issue and not the result :wink:

@Saiyato: any news on this? or is there a hack (like changing file permission)? or can you name the last version of volumio within your snapcast plugin is working? I need a working volumio/snapcast environment otherwise there is no music…

Same issue here with RPI3B Hifiberry DAC+ volumio v2.692

Same here as well with all 3 rpi’s and also with older Volume images as I had t install that as hte latest Volume image has volume settings problems.

same here
really painful
tried to manually install 2.4.5 from GitHub repo, same thing
Startup failed

Could not start the SnapCast plugin in a fashionable manner.
Restart failed
Restarting snapserver failed with error: Error: Command failed: /usr/bin/sudo /bin/systemctl restart snapserver Failed to restart snapserver.service: Unit snapserver.service is masked.

I’m not specialist for snapcast but you can try : systemctl unmask snapserver systemctl restart snapserver

Will try that as well.
Hopefully it will help.

Verstuurd vanaf mijn SM-G960F met Tapatalk

I think I have the same issue. I just installed volumio on 3 different pi’s today. Everything works except for snapcast and I’m getting the errors and behavior as described in this post.

Hoping for a fix

this is not working for me:

volumio@js_musicserver:~$ systemctl unmask snapserver Removed symlink /etc/systemd/system/snapserver.service. volumio@js_musicserver:~$ systemctl restart snapserver Failed to restart snapserver.service: Unit snapserver.service failed to load: No such file or directory.

I am having the same or a similar issue.
I have tried fresh volumio install on both a RPi 3B+ and RPi 4 with same result on both systems.
Volumio is ok except the snapcast plugin won’t work.
I think the installation actually fails (There are 2 lines in the ‘Details’ during installation saying ‘removing snapclient’ and ‘removing snapserver’), however volumio thinks that the installation was succesfull.

I then tried manual installation of the latest snapserver on the RPi4 and a similar thing happened:
= The package installation ends with dependency error and states to run ‘sudo apt - f install’
= executing “sudo apt -f install” then results in removing snapserver instead of fixing the dependency
Same thing happens when trying to install the snapclient package mannualy

Tried also many things without success.
Hopefully somebody has a solution.

It would also be nice if you could put some delays here and there as I don’t have the same configuration at several places and synchronization fails .


Verstuurd vanaf mijn SM-G960F met Tapatalk

Same here, there are problems with dependencies in Jessie.

Does anybody have an older version of snapcast server installed just to try?


You can try to pull the latest one from github instead, that one is loaded with a previous version of SnapCast which does work on Jessie.


When wil this be fixed…

I want to use the plugin.

Thanks, Ad.

Verstuurd vanaf mijn SM-G960F met Tapatalk

Hi Ad,

I’ve put some time in addressing some of the issues, please do keep in mind we’re doing this in our spare time :wink:
There’s still some testing to do before I’m comfortable committing to the store.