SMSL Sanskrit 10th MK II - bitrate issue

Hi everyone, I am using the Sanskrit Mk II with a Rpi4 2GB and Volumio 3, and it plays fine but stuck to 44.1. Volumio does detect the DAC and identifies it correctly. I have connected a secondary USB cable to a 5V 1A mobile charger, but no change. DSD files also show "44’ in the screen, and DSD Direct is enabled. This DAC is DSD-capable.

This message is not about DSD files, regular FLAC files with different bitrates (48, 96 etc) are showing “44” as well.

I used the DAC with my PC and it did change the bitrate according to the played file. I even used it with a Sparky SBC with Volumio 2 and it switched automatically to the native bitrate of the file.

I have tried a different couple of USB cables but still getting the same result.
Has anyone been able to make it work with the Rpi4 and Volumio?

Ps. Another user shared the below in November 2020:

Please supply us with some logs, it is difficult to analyse from what you have given us. Thanks.
How to send a log

Sorry my bad, here you have the logs:

Ok, you did not mention you are using the DSP plugin, you should describe your issue and your environment more clearly the next time please :wink:
I can’t help with this.
@balbuze ??

FusionDsp as it works with the Alsa workaround stay stuck on the first sample rate used. Soif a 44.1kHz file is played right after enabling the plugin, it will stay on that value.
We are working to fix this issue on a next version.

1 Like

Sorry once more - I completely forgot about the DSP plugin. I have just tried disabling the plugin and… voila, the correct bitrate is displayed. If it’s better I will continue this conversation in the DSP plugin thread, in case there’s one.
Thanks @gkkpch for pointing this out.
Thanks @balbuze for the explanation, I will keep an eye on the next versions (and thanks a ton for your incredible work).